Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229693 - objectclass without parent causes null pointer in console
Summary: objectclass without parent causes null pointer in console
Keywords:
Status: CLOSED DUPLICATE of bug 234948
Alias: None
Product: 389
Classification: Retired
Component: UI - Configuration
Version: 1.0.4
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-22 20:02 UTC by Aaron Luchko
Modified: 2015-01-04 23:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-05 18:16:53 UTC


Attachments (Terms of Use)
The stack trace from the null pointer (deleted)
2007-02-22 20:02 UTC, Aaron Luchko
no flags Details

Description Aaron Luchko 2007-02-22 20:02:22 UTC
Description of problem:

Null pointer in the console when trying to add an objectclass with a schema that
 has an objectclass with an attribute that is defined in another schema but the
objectclass doesn't inherit from any objectclasses in that schema.

Version-Release number of selected component (if applicable):

fedora-ds-1.0.4-1.Linux

How reproducible:

Always

Steps to Reproduce:
1. Install fedora-ds and run setup (defaults are fine)
2. Add the following schema:
# cat /opt/fedora-ds/slapd-localhost/config/schema/61-maillist.ldif
dn: cn=schema
attributeTypes: ( 1.3.6.1.4.1.18320.1.2 NAME 'maildrop' DESC 'Email account or
username to deliver all email to' SYNTAX 1.3.6.1.4.1.1466.115.121.1.26 X-ORIGIN
'A Postfix Schema' )
objectClasses: ( 1.3.6.1.4.1.18320.2.1 NAME 'PostfixUser' DESC 'Email user with
a live email box at HCI' MUST (maildrop $ mail) X-ORIGIN 'A Postfix Schema' )

and restart the server

3. run startconsole and open the server localhost, in the directory tab select
localdomain and go New > Other
Select postfixuser from the list and hit Ok

You get the attached null pointer and the new object window never comes up.

Comment 1 Aaron Luchko 2007-02-22 20:02:22 UTC
Created attachment 148615 [details]
The stack trace from the null pointer

Comment 2 Aaron Luchko 2007-02-22 20:13:43 UTC
I've added bug 229699 which describes a different error but with what is likely
the same underlying problem

Comment 3 Aaron Luchko 2007-02-23 03:08:37 UTC
Turns out that this bug only occurs when the objectclass doesn't inherit from
another (ie 'SUP top'), which it appears it's supposed to, and the attribute
thing has nothing to do with it.

It still results in a null pointer though I'm wondering if ns-slapd should even
start if the schema is invalid (which I think it is without the SUP).

Comment 5 Rich Megginson 2008-12-05 18:16:53 UTC

*** This bug has been marked as a duplicate of bug 234948 ***


Note You need to log in before you can comment on or make changes to this bug.