Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229692 - "yum provides hid2hci" only works if bluez-utils is installed
Summary: "yum provides hid2hci" only works if bluez-utils is installed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-22 20:00 UTC by Pete Zaitcev
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-25 19:22:30 UTC


Attachments (Terms of Use)

Description Pete Zaitcev 2007-02-22 20:00:14 UTC
Description of problem:

Running "yum provides hid2hci" only works if bluez-utils is installed,
but this makes no sense, because it's impossible to find necessary RPMs
this way.

Version-Release number of selected component (if applicable):

yum-3.1.2-1.fc7

How reproducible:

Always

Steps to Reproduce:
1. Run "rpm -e bluez-utils" to ensure it's not installed
2. Run "yum provides hid2hci", it returns "No Matches found".
   This is our problem.
3. Run "yum install -y bluez-utils"
4. Run "yum provides hid2hci", it returns the RPM

Actual results:

No match

Expected results:

Report on the RPM which provides the binary

Additional info:

Running "yum provides hid2hci" loads filelists.xml.gz, just finds nothing.

The bluez-utils does NOT provide hid2hci. Running "rpm -q --provides
bluez-utils" only reports bluez-utils, but not names of binaries.

The man page specifies the current behaviour: "used to find out which
package _provides_ some feature or file". So we can say that it's
strict provides... but then the behaviour changes if RPM is installed.
That just makes no sense and is useless. If RPM is installed already,
I can find to which rpms a file belongs without resorting to yum.

Comment 1 Jeremy Katz 2007-04-25 19:22:30 UTC
You have to use the full pathname (and things are consistent between installed
and not now)


Note You need to log in before you can comment on or make changes to this bug.