Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229663 - Package Updater Dump Information
Summary: Package Updater Dump Information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
: 229769 229773 229777 229804 229823 229839 229844 229845 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-22 16:32 UTC by Al Cranford
Modified: 2013-01-10 01:35 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-23 17:07:21 UTC


Attachments (Terms of Use)
Package Updater dump information (deleted)
2007-02-22 16:32 UTC, Al Cranford
no flags Details

Description Al Cranford 2007-02-22 16:32:04 UTC
Description of problem:
When I try to run the Package Updater I get a list of updates available but when
I click the "Apply Updates" button I get the following error:

Component: Software Updater
Summary: TBccefa5c9 yumRepo.py:426:__get:RepoError: failure:
spamassassin-3.1.8-2.fc6.i386.rpm from updates: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 433, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 559, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 324, in checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 150, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 760, in
downloadHeader
    cache=repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 454, in getHeader
    cache=cache,
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 426, in __get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
RepoError: failure: spamassassin-3.1.8-2.fc6.i386.rpm from updates: [Errno 256]
No more mirrors to try.

Local variables in innermost frame:
e: [Errno 256] No more mirrors to try.
start: 440
url: None
text: None
self: updates
cache: True
reget: None
relative: spamassassin-3.1.8-2.fc6.i386.rpm
headers: ()
checkfunc: (<bound method PackageUpdater.verifyHeader of
<__main__.PackageUpdater object at 0x976b84c>>,
(<yum.sqlitesack.YumAvailablePackageSqlite object at 0xaadfecc>, 1), {})
copy_local: 1
end: 49616
local: //var/cache/yum/updates/headers/spamassassin-3.1.8-2.fc6.i386.hdr


Version-Release number of selected component (if applicable):
See above

How reproducible:
Three out of three times

Steps to Reproduce:
1. Run Pup
2. Click apply updates

  
Actual results:


Expected results:


Additional info:
I also tried "yum update" and after trying all mirrors it also stopped with 
Error: failure: spamassassin-3.1.8-2.fc6.i386.rpm from updates: [Errno 256] No
more mirrors to try.

Comment 1 Al Cranford 2007-02-22 16:32:04 UTC
Created attachment 148590 [details]
Package Updater dump information

Comment 2 PLa 2007-02-23 15:51:10 UTC
(In reply to comment #1)
> Created an attachment (id=148590) [edit]
> Package Updater dump information
> 


Here's my exception summary:


Component: Software Updater
Summary: TBccefa5c9 yumRepo.py:426:__get:RepoError: failure:
repodata/updateinfo.xml.gz from updates-32bit: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 319, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 375, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 227, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 615, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 426, in __get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
RepoError: failure: repodata/updateinfo.xml.gz from updates-32bit: [Errno 256]
No more mirrors to try.

Local variables in innermost frame:
e: [Errno 256] No more mirrors to try.
start: None
url: None
text: None
self: updates-32bit
cache: True
reget: None
relative: repodata/updateinfo.xml.gz
headers: ()
checkfunc: (<bound method YumRepository.checkMD of <yum.yumRepo.YumRepository
object at 0xf03cd0>>, ('updateinfo',), {})
copy_local: 1
end: None
local: //var/cache/yum/updates-32bit/updateinfo.xml.gz


Comment 3 Jeremy Katz 2007-02-23 16:02:02 UTC
repomd.xml references the updateinfo.xml, but it's not there.  Something broke
in the push process.

Comment 4 Jeremy Katz 2007-02-23 16:02:26 UTC
*** Bug 229777 has been marked as a duplicate of this bug. ***

Comment 5 Jeremy Katz 2007-02-23 16:02:30 UTC
*** Bug 229773 has been marked as a duplicate of this bug. ***

Comment 6 Jeremy Katz 2007-02-23 16:03:06 UTC
*** Bug 229769 has been marked as a duplicate of this bug. ***

Comment 7 Jesse Keating 2007-02-23 17:07:21 UTC
I did a new push to fix this.  That metadata is now on place.  Should filter out
to the mirrors soon.

Comment 8 Jeremy Katz 2007-02-23 18:04:00 UTC
*** Bug 229804 has been marked as a duplicate of this bug. ***

Comment 9 Jeremy Katz 2007-02-23 18:04:19 UTC
*** Bug 229823 has been marked as a duplicate of this bug. ***

Comment 10 Jeremy Katz 2007-02-23 20:05:47 UTC
*** Bug 229839 has been marked as a duplicate of this bug. ***

Comment 11 Jeremy Katz 2007-02-23 20:06:05 UTC
*** Bug 229844 has been marked as a duplicate of this bug. ***

Comment 12 Jeremy Katz 2007-02-23 20:06:22 UTC
*** Bug 229845 has been marked as a duplicate of this bug. ***

Comment 13 Jeremy Katz 2007-02-26 14:24:46 UTC
*** Bug 229972 has been marked as a duplicate of this bug. ***

Comment 14 Adam Huffman 2007-03-05 21:57:49 UTC
Just to note that I saw this for the first time tonight:

Component: Software Updater
Summary: TBe634e670 __init__.py:767:downloadHeader:RepoError: failure:
nss-3.11.5-0.6.1.fc6.i
386.rpm from updates: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 433, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 559, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 324, in checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 150, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 767, in
downloadHeader
    raise Errors.RepoError, saved_repo_error
RepoError: failure: nss-3.11.5-0.6.1.fc6.i386.rpm from updates: [Errno 256] No
more mirrors t
o try.

Local variables in innermost frame:
errors: {}
e: [Errno 2] No such file or directory:
'//var/cache/yum/updates/headers/nss-3.11.5-0.6.1.fc6
.i386.hdr'
self: <__main__.PackageUpdater object at 0xcc1a90>
saved_repo_error: failure: nss-3.11.5-0.6.1.fc6.i386.rpm from updates: [Errno
256] No more mi
rrors to try.
repo: updates
checkfunc: (<bound method PackageUpdater.verifyHeader of
<__main__.PackageUpdater object at 0
xcc1a90>>, (<yum.sqlitesack.YumAvailablePackageSqlite object at 0x25dcf90>, 1), {})
local: //var/cache/yum/updates/headers/nss-3.11.5-0.6.1.fc6.i386.hdr
po: nss - 3.11.5-0.6.1.fc6.i386



Note You need to log in before you can comment on or make changes to this bug.