Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229662 - XML validation errors when using DRAC fencing with Blades
Summary: XML validation errors when using DRAC fencing with Blades
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 247731
TreeView+ depends on / blocked
 
Reported: 2007-02-22 16:30 UTC by Andrew Cathrow
Modified: 2014-09-07 22:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-22 19:23:18 UTC


Attachments (Terms of Use)
Sample cluster.conf created by s-config-cluster (deleted)
2007-02-22 16:30 UTC, Andrew Cathrow
no flags Details
Patch to allow modulename as a parameter in xml for drac interfaces. (deleted)
2007-07-11 04:02 UTC, Wade Mealing
no flags Details | Diff

Description Andrew Cathrow 2007-02-22 16:30:13 UTC
Description of problem:


Version-Release number of selected component (if applicable):
Running RHEL4U4 x86 with all errata applied.
System-config-cluster is version 1.0.27-1.0

After setting up cluster.conf to use DRAC fencing with a Dell Blade system the
system-config-cluster tool gives an XML validation error.



tmp/cluster.conf:8: element device: Relax-NG validity error : Invalid attribute
modulename for element device
Relax-NG validity error : Extra element fence in interleave
/tmp/cluster.conf:4: element clusternodes: Relax-NG validity error : Element
clusternode failed to validate content
/tmp/cluster.conf:5: element clusternode: Relax-NG validity error : Element
clusternodes has extra content: clusternode
/tmp/cluster.conf:6: element fence: Relax-NG validity error : Element
clusternode has extra content: fence
/tmp/cluster.conf:2: element cluster: Relax-NG validity error : Invalid sequence
in interleave
/tmp/cluster.conf:2: element cluster: Relax-NG validity error : Element cluster
failed to validate content
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf fails to validate



How reproducible:
100%tmp/cluster.conf:8: element device: Relax-NG validity error : Invalid
attribute modulename for element device
Relax-NG validity error : Extra element fence in interleave
/tmp/cluster.conf:4: element clusternodes: Relax-NG validity error : Element
clusternode failed to validate content
/tmp/cluster.conf:5: element clusternode: Relax-NG validity error : Element
clusternodes has extra content: clusternode
/tmp/cluster.conf:6: element fence: Relax-NG validity error : Element
clusternode has extra content: fence
/tmp/cluster.conf:2: element cluster: Relax-NG validity error : Invalid sequence
in interleave
/tmp/cluster.conf:2: element cluster: Relax-NG validity error : Element cluster
failed to validate content
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf fails to validate



Steps to Reproduce:
This error occurs if you use the modulename option with DRAC fencing to specify
the module within a blade chassis.
See attached sample cluster.conf- created in system-config-cluster


The fix seems to be adding a modulename section to the FENCE schema.
Tested ok with my customer's configuration file.

 <group> 
  <attribute name="modulename"/>
 </group>

Comment 1 Andrew Cathrow 2007-02-22 16:30:13 UTC
Created attachment 148589 [details]
Sample cluster.conf created by s-config-cluster

Comment 2 Wade Mealing 2007-07-11 04:02:05 UTC
Created attachment 158922 [details]
Patch to allow modulename as a parameter in xml for drac interfaces.

Apparently fixed as mentioned in:
http://post-office.corp.redhat.com/archives/cluster-list/2007-February/msg00215.html


But this does not work. This may also be valid for RHEL5 clusters also.

Comment 3 Wade Mealing 2007-07-12 00:11:13 UTC
Ok, looks like its fixed over in the other bzilla by parsons.

Comment 5 Lon Hohberger 2010-01-22 19:23:18 UTC
This is fixed in system-config-cluster-1.0.54-2.0.  I did not check earlier releases.  Not sure why it wasn't closed.


Note You need to log in before you can comment on or make changes to this bug.