Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229637 - Epoch for thunderbird in FC6
Summary: Epoch for thunderbird in FC6
Keywords:
Status: CLOSED DUPLICATE of bug 227860
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-22 12:48 UTC by Andrew C Aitchison
Modified: 2018-04-11 07:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-04 20:35:23 UTC


Attachments (Terms of Use)

Description Andrew C Aitchison 2007-02-22 12:48:29 UTC
Description of problem:

The thunderbird package in FC6 has epoch 0, but the package in updates has
no Epoch at all.

Version-Release number of selected component (if applicable):

thunderbird-0:1.5.0.7-4.fc6.x86_64.rpm
thunderbird-(none):1.5.0.9-7.fc6.x86_64.rpm

Steps to Reproduce:
1. wget
http://download.fedora.redhat.com/pub/fedora/linux/core/6/x86_64/os/Fedora/RPMS/thunderbird-1.5.0.7-4.fc6.x86_64.rpm
 wget
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/x86_64/thunderbird-1.5.0.9-7.fc6.x86_64.rpm


2.
rpmquery -p --qf '%{name}-%{epoch}:%{version}-%{release}.%{arch}.rpm\n' thunderbird*
thunderbird-0:1.5.0.7-4.fc6.x86_64.rpm
thunderbird-(none):1.5.0.9-7.fc6.x86_64.rpm

yum is happy that thunderbird-1.5.0.9-7.fc6.x86_64.rpm is newer than
thunderbird-1.5.0.7-4.fc6.x86_64.rpm but I have tools that think that
Epoch 0 is newer than Epoch (none).

Additional info:

Comment 2 Christopher Aillon 2007-03-04 20:35:23 UTC
This isn't a bug in thunderbird, really.  Epoch 0 is the same as no epoch.  It
only matters because rpm python bindings are broken and produces the wrong
result for the version comparison.  See the dupe.

*** This bug has been marked as a duplicate of 227860 ***


Note You need to log in before you can comment on or make changes to this bug.