Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229607 - Rawhide kernel fails to boot on Macbook Pro
Summary: Rawhide kernel fails to boot on Macbook Pro
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-02-22 01:30 UTC by David Zeuthen
Modified: 2013-03-06 03:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-15 19:41:50 UTC


Attachments (Terms of Use)
the backtrace (deleted)
2007-02-22 01:30 UTC, David Zeuthen
no flags Details
another backtrace (deleted)
2007-03-07 16:14 UTC, Rafael Ávila de Espíndola
no flags Details

Description David Zeuthen 2007-02-22 01:30:23 UTC
Description of problem:

kernel panic (I think) on bootup. Will attach picture from my digicam.

Version-Release number of selected component (if applicable):

kernel-2.6.20-1.2936.fc7

How reproducible:

Always. Tried booting five times.

Steps to Reproduce:

This is on a Macbook Pro with a Core Duo (not Core2; it's 1st generation Macbook
Pro).

Comment 1 David Zeuthen 2007-02-22 01:30:24 UTC
Created attachment 148555 [details]
the backtrace

Comment 2 Andrew Cathrow 2007-02-22 13:27:04 UTC
Just reproduced the same on a MacBook with core-2-duo.
Tried this on 2936 and 2911 with same result. Last kernel that I have that
appears to work is 2.6.20-1-2898.2.3.fc7

Unable to get a trace other than taking a photo, and David's trace is identical
to mine.

This happens immediately after

PCI: Using MMCONFIG
Setting up standard PCI resources

I've tried pci=nommconf incase that's the issue and various combinations of pci=
but I'm still unable to boot

Comment 3 Ruben Kerkhof 2007-02-24 19:59:55 UTC
I can confirm this on my Macbook Pro first generation as well.

Comment 4 David Zeuthen 2007-03-03 20:03:32 UTC
Still happening with .2962...

Comment 5 Rafael Ávila de Espíndola 2007-03-05 03:18:47 UTC
compiling without CONFIG_DEBUG_MUTEXES "solves" the problem. The problem is also
present on linus git tree.

Comment 6 Rafael Ávila de Espíndola 2007-03-07 06:21:59 UTC
I tried to us netconsole to get a better trace, but the kernel crashes before
the netconsole is up :-(
I want to help, but I think that I will need some information on how to debug this.

Comment 7 Rafael Ávila de Espíndola 2007-03-07 16:14:05 UTC
Created attachment 149461 [details]
another backtrace

Comment 8 Rafael Ávila de Espíndola 2007-03-14 05:11:58 UTC
Fixed on 2985


Comment 9 Will Woods 2007-03-15 19:18:50 UTC
davidz, can you confirm that this problem is fixed in kernel .2985 and later?

Comment 10 David Zeuthen 2007-03-15 19:41:50 UTC
Yeah, latest Rawhide boots. Thanks. Closing this bug.


Note You need to log in before you can comment on or make changes to this bug.