Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229597 - Author search broken
Summary: Author search broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: slrn
Version: 5
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Update FC6Update
TreeView+ depends on / blocked
 
Reported: 2007-02-21 22:50 UTC by Lauri Nurmi
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-23 11:13:30 UTC


Attachments (Terms of Use)
Fix for author search (deleted)
2007-02-21 22:50 UTC, Lauri Nurmi
no flags Details | Diff

Description Lauri Nurmi 2007-02-21 22:50:49 UTC
Description of problem:
The "Author search" feature is broken.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Start slrn, enter a group
2. Press 'a' to search by author
3. Enter a search term that obviously should be found
  
Actual results:
The search doesn't find anything (or at least not what you wanted). That is
because it is searching for _subjects_, not authors.

Expected results:
Should be searching for authors with author search.

Additional info:
This bug exists in all FC versions from (at least) FC5 to FC7test1. I found a
fix from slrn's CVS, please see the attached patch. A simple 2-line fix.

Comment 1 Lauri Nurmi 2007-02-21 22:50:49 UTC
Created attachment 148546 [details]
Fix for author search

Comment 2 Miroslav Lichvar 2007-02-22 17:18:09 UTC
Fixed in slrn-0.9.8.1pl1-2.fc5.


Note You need to log in before you can comment on or make changes to this bug.