Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229580 - hald gets "general protection"
Summary: hald gets "general protection"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-21 21:31 UTC by Michal Jaegermann
Modified: 2013-03-06 03:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-06 22:10:54 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2007-02-21 21:31:13 UTC
Description of problem:

This is what started to show up in logs recently:

hald[2595] general protection rip:37d0a75060 rsp:7fff178c5f28 error:0

Unfortunately no core file I can find.  If you login after that
then a deskop is quite unhappy and various alerts that things do
not work show up. 'hald' indeed is dead.

I got three of these recently.  They are preceded directly with messages
(the same datestamp) like those:
....
gconfd (root-12296): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source
at position 2
gconfd (root-12296): Exiting
kernel: hald[2595] general protection ....
.....

AFAICT in all cases this really meant a logout from a gnome-session.
Two times it was after a bunch up updates was applied but other time
I do not see anything special.  OTOH this does not happen after
every logout. "rip:37d0a75060 rsp:7ffffa1e1848 error:0" is the same
on every occasion.

Version-Release number of selected component (if applicable):
hal-0.5.9-0.git20070218.fc7

How reproducible:
See above.

Comment 1 David Zeuthen 2007-02-21 21:43:30 UTC
yeah, there's an annoying segfault somewhere (seen it on x86 too) and I guess
the x86_64 kernel just logs such things (the ia64 kernel prints even more crap).
I'll try to hunt this down for the next git snapshot (which is in a couple of
days...)

Comment 2 Deji Akingunola 2007-02-24 06:42:13 UTC
Can it be consolekit related? I've been experiencing similar issue when
switching user using F-U-S-A.

Comment 3 David Zeuthen 2007-03-05 19:58:41 UTC
Is this still happening with hal-0.5.9-0.git20070304.fc7? Thanks.

Comment 4 Michal Jaegermann 2007-03-05 20:50:51 UTC
> Is this still happening with hal-0.5.9-0.git20070304.fc7?
I did not see that so far but I did not have a recipe to recreate
that at will.  I intended to wait a bit ...

Comment 5 Michal Jaegermann 2007-03-06 22:10:54 UTC
If previous patterns would be kept then hald should crash by now and
the last one I have seen was immediately after an update (which will
be still the previous version running).

I guess that I will close that at this moment and if something
bad will happen then will reopen.


Note You need to log in before you can comment on or make changes to this bug.