Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229575 - yum, yumex, pup crashing after transaction info
Summary: yum, yumex, pup crashing after transaction info
Keywords:
Status: CLOSED DUPLICATE of bug 229582
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: i686
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-21 21:16 UTC by George Boyd
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-21 22:08:47 UTC


Attachments (Terms of Use)

Description George Boyd 2007-02-21 21:16:03 UTC
Description of problem:
Everytime I run yumex, pup, or yum. After it gathers the transaction Info info I
get this cradh dump.

Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1. Run any of the above mentioned programs
2.
3.
  
Actual results:
Component: Software Updater
Summary: TBb09601ff packages.py:35:comparePoEVR:AttributeError: 'NoneType'
object has no attribute 'epoch'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 433, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 559, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 328, in checkDeps
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442, in
buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fedorakmod.py", line 273, in postresolve_hook
    newKernels + installedKernels)
  File "/usr/lib/yum-plugins/fedorakmod.py", line 228, in installAllKmods
    table = resolveVersions(interesting + modules)
  File "/usr/lib/yum-plugins/fedorakmod.py", line 152, in resolveVersions
    elif sameName == None:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191, in __eq__
    if comparePoEVR(self, other) == 0 and self.arch == other.arch and self.name
== other.name:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 35, in comparePoEVR
    (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
AttributeError: 'NoneType' object has no attribute 'epoch'

Local variables in innermost frame:
po2: None
v1: 1.0.9631
e1: 0
r1: 4.2.6.19_1.2911.fc6
po1: kmod-nvidia-96xx - 1.0.9631-4.2.6.19_1.2911.fc6.i686



Expected results:
I expect it to work

Additional info:

Comment 1 Jeremy Katz 2007-02-21 22:08:47 UTC

*** This bug has been marked as a duplicate of 229582 ***


Note You need to log in before you can comment on or make changes to this bug.