Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229571 - Anaconda takes an inordinate amount of time to grab a dynamic IP
Summary: Anaconda takes an inordinate amount of time to grab a dynamic IP
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-21 21:07 UTC by Steve Salevan
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-05 19:39:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Steve Salevan 2007-02-21 21:07:12 UTC
Description of problem:
If a user attempts to run anaconda to install RHEL 5 on a client, it can
sometimes take Anaconda over a half hour to get a dynamic IP address through its
ethernet interface from a DHCP server.

Version-Release number of selected component (if applicable):
RHEL 5 Gold

How reproducible:
Always (at least when I try it)

Steps to Reproduce:
1. Start a RHEL 5 installation via CD or a kickstart on a machine 
2. Wait until anaconda attempts to get a dynamic IP
3. Continue waiting
  
Actual results:
Anaconda finds an IP, but it takes over a half hour for it to do such.

Expected results:
Anaconda finds an IP within 5 minutes or so.

Additional info:
The test plan was run on a VMware box, and the RHEL 5 Gold installation was
initiated through an RHN Satellite-based kickstart.

Comment 1 Jeremy Katz 2007-02-26 19:52:32 UTC
Adding 'noipv6' to your kernel command line will make things faster if you don't
have IPv6 set up on your network

Comment 2 David Cantrell 2007-03-06 21:09:40 UTC
Need more details about your network.  Half an hour seems a bit long.  I would
believe 10 minutes, which is the RFC required timeout.

There seems to be something unique about your network setup.  You also had the
bug report about noipv6 causing a SIGSEGV.  Either you have an old release of
RHEL-5 or your network contains things that we are not accounting for correctly.

Make sure you are using RHEL-5 GOLD.

Comment 3 David Cantrell 2007-04-05 19:39:43 UTC

*** This bug has been marked as a duplicate of 231645 ***


Note You need to log in before you can comment on or make changes to this bug.