Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229523 - Exception Occurred at Yumex startup
Summary: Exception Occurred at Yumex startup
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 237785 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-21 18:29 UTC by Guy L. Pace
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-28 10:43:58 UTC


Attachments (Terms of Use)
this is the debug traceback text (deleted)
2007-02-21 18:29 UTC, Guy L. Pace
no flags Details

Description Guy L. Pace 2007-02-21 18:29:46 UTC
Description of problem:
Installed Yumex 1.2.2 and set proxy to correct settings. Restarted Yumex and get
Exception Occurred

Version-Release number of selected component (if applicable):
1.2.2

How reproducible:
Start Yumex with proxy configured.

Steps to Reproduce:
1. Applications, System Tools, Yumex
2. Application loads repostitories, then crashes.
3.
  
Actual results:
Component: yumex
Version: 1.2.2
Summary: TB03120a34 yumexmain.py:1045:_runBackground:TypeError: iterable
argument required

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1108, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 541, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 990, in setup_yum
    self._runBackground( self.yumexbase.set_active_repos,
self.repoView.get_selected() )
  File "/usr/share/yumex/yumexmain.py", line 1045, in _runBackground
    raise self.backgroundThread.exception
TypeError: iterable argument required

Local variables in innermost frame:
runfunc: <bound method yumexBase.set_active_repos of <yumex.yumexBase.yumexBase
object at 0xd01910>>
args: (['core', 'extras', 'updates'],)
self: <__main__.YumexMainApplication instance at 0xcf6518>


Expected results:
Should allow me to update, install or whatever. Have yet to see what application
can do.

Additional info: running AMD Turion64 and Fedora Core 6, x86-64.

Comment 1 Guy L. Pace 2007-02-21 18:29:46 UTC
Created attachment 148520 [details]
this is the debug traceback text

Comment 2 Dawid Zamirski 2007-04-24 14:52:34 UTC
Ok, I was able to reporoduce the problem you're having. This is defintely a
Yumex bug and I'll try to patch it today. For now, you can workaround this
problem by specifying the protocol in your proxy setting:
Assuming that the proxy server address you entered was somepoxy.com, make sure
that you specify the protocol by adding "http://" before it:
http://someproxy.com You can change this in /etc/yumex.conf file.

Comment 3 Dawid Zamirski 2007-04-24 16:52:44 UTC
I have just committed the fix to SVN repo so it should be fixed in the next
release of yumex-1.2.x

Comment 4 Tim Lauridsen 2007-05-01 09:00:45 UTC
Thanks Dawid, for fixing the issue for yumex 1.2.x, can you added the changes to
yumex-1.9.x too

Comment 5 Tim Lauridsen 2007-05-01 09:04:34 UTC
*** Bug 237785 has been marked as a duplicate of this bug. ***

Comment 6 Dawid Zamirski 2007-05-01 13:47:48 UTC
Tim, this issue doesn't seem to apply to 1.9.X branch - at least I couldn't
reproduce because it doesn't crash no matter what the proxy addreess in
yumex.conf is.


Note You need to log in before you can comment on or make changes to this bug.