Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229512 - weak-modules doesn't have an option not to make an initrd
Summary: weak-modules doesn't have an option not to make an initrd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: module-init-tools
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jon Masters
QA Contact: David Lawrence
URL:
Whiteboard:
: 234489 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-21 17:32 UTC by Jon Masters
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: RHBA-2007-0659
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 17:25:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0659 normal SHIPPED_LIVE module-init-tools bug fix and enhancement update 2007-10-30 15:04:13 UTC

Description Jon Masters 2007-02-21 17:32:02 UTC
The /sbin/weak-modules script will always generate a new initrd (and throw it
away if it's not needed). Sometimes, this behavior is not desired and should be
disabled for specific invocations of the weak-modules script. This is especially
true when it is driven by an external program, such as dkms.

Suggest a new flag --no-initrd that causes no initrd to be created.

Jon.

Comment 2 Jon Masters 2007-04-10 09:47:03 UTC
*** Bug 234489 has been marked as a duplicate of this bug. ***

Comment 3 RHEL Product and Program Management 2007-04-25 21:16:44 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 6 Jon Masters 2007-06-06 06:23:18 UTC
Tagged with: module-init-tools-3_3-0_pre3_1_21_el5

Comment 11 errata-xmlrpc 2007-11-07 17:25:48 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0659.html



Note You need to log in before you can comment on or make changes to this bug.