Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229500 - glibc 2.5-10 and wacom driver leads to Xorg crash
Summary: glibc 2.5-10 and wacom driver leads to Xorg crash
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 6
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-21 16:24 UTC by Dawid Zamirski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-27 01:55:54 UTC


Attachments (Terms of Use)

Description Dawid Zamirski 2007-02-21 16:24:39 UTC
Description of problem:
While using linuxwacom package that is under review for Extras (bug #220706), my
Xserver crashed when loading wacom_drv module. It was happening regardless
whether I was using module built from the src.rpm or straight from upstream
tar.gz (including newest beta). After downgrading to glib 2.5-3 the issue went
away and I'm able to sucessfully start X with wacom module loaded.

Version-Release number of selected component (if applicable):
glibc-2.5-10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Compile and install wacom module from  linuxwacom project (can be stable
7.6-4 or beta 7.7 version). 
2. Edit xorg.conf to make use of the module
3. When restarting Xthe server will not start with fatal server error. 
  
Actual results:
Last few lines of xorg.log after crash:

(II) LoadModule: "kbd"
(II) Loading /usr/lib64/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.1.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.6
(II) LoadModule: "wacom"
(II) Loading /usr/lib64/xorg/modules/input/wacom_drv.o
(II) Module wacom: vendor="X.Org Foundation"
	compiled for 4.3.99.902, module version = 1.0.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.6

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x71) [0x496141]
1: /lib64/libc.so.6 [0x3fa1c30210]
2: [0xa1f320]

Fatal server error:
Caught signal 11.  Server aborting


Expected results:
X server should start sucessfully

Additional info:
Downgradig glibc to 2.5-3 in Core solves the problem.

Comment 1 Jakub Jelinek 2007-02-22 08:39:52 UTC
That's not a proof the bug is on the glibc side, far more likely that
the driver called a libc function with bogus arguments.
From the backtrace it is not clear which function it was.  If libc is prelinked,
then it should be usually mapped in the same location, so please:
- install glibc-2.5-10 back
- run as root /etc/cron.daily/prelink
- try to reproduce the problem, is successful, note the address in libc.so.6
  and find it in objdump -dr /lib64/libc.so.6 output

Comment 2 Dawid Zamirski 2007-02-27 01:55:54 UTC
Hi

I gave updated my glibc back to 2.5-10 and cannot reproduce the problem anymore
:-/ I've also rebuilt the drivers again but it seems that the issue went away
for some reson. While it's sort of a good thing, I have no clue what was cusing
the X crashes eariler as I could reproduce them everytime until I downgraded to
2.5-3. Regardless, I think that this bug can be closed :-)


Note You need to log in before you can comment on or make changes to this bug.