Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229483 - ia64: build fails in mon_bin_exit & mon_text_exit
Summary: ia64: build fails in mon_bin_exit & mon_text_exit
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Prarit Bhargava
QA Contact: Brian Brock
URL:
Whiteboard: bzcl34nup
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-21 14:31 UTC by Prarit Bhargava
Modified: 2008-04-15 17:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-15 17:04:17 UTC


Attachments (Terms of Use)
Upstream fix for this issue (deleted)
2007-02-21 14:31 UTC, Prarit Bhargava
no flags Details | Diff
Fedora fix for this issue (deleted)
2007-02-21 14:44 UTC, Prarit Bhargava
no flags Details | Diff

Description Prarit Bhargava 2007-02-21 14:31:03 UTC
Description of problem:

Build fails due to MODPOST warnings.

Version-Release number of selected component (if applicable):
kernel-2.6.20-1.2932.fc7


How reproducible: 100%


Steps to Reproduce:
1. attempt to build from src rpm

  
Actual results:

Build fails with MODPOST warnings:

`mon_bin_exit' referenced in section `.init.text' of drivers/built-in.o: defined
in discarded section `.exit.text' of drivers/built-in.o
`mon_text_exit' referenced in section `.init.text' of drivers/built-in.o:
defined in discarded section `.exit.text' of drivers/built-in.o
make: *** [.tmp_vmlinux1] Error 1

Expected results:  Build should succeed.


Additional info: Upstream patch pushed 2007-02-21.

Comment 1 Prarit Bhargava 2007-02-21 14:31:03 UTC
Created attachment 148483 [details]
Upstream fix for this issue

Comment 2 Prarit Bhargava 2007-02-21 14:44:11 UTC
Created attachment 148487 [details]
Fedora fix for this issue

Comment 3 Bug Zapper 2008-04-03 19:13:01 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.


Note You need to log in before you can comment on or make changes to this bug.