Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229480 - dom0: panic w/X on i965 (appears to be agpgart?)
Summary: dom0: panic w/X on i965 (appears to be agpgart?)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eduardo Habkost
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-21 13:41 UTC by Davide Bolcioni
Modified: 2009-12-14 20:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-26 23:56:04 UTC


Attachments (Terms of Use)

Description Davide Bolcioni 2007-02-21 13:41:01 UTC
+++ This bug was initially created as a clone of Bug #214635 +++

Description of problem:

Usage of X on i965 under dom0 often panics the kernel, leading to a fault that
spontaneously reboots the machine.

Operations that can cause this:

1) starting X (has happened in gdm)

Comment 1 Davide Bolcioni 2007-02-21 13:45:07 UTC
In my case, the problem manifests with display corruption of the lower half of 
the X display and a garbled cursor (running KDE) but the host is apparently 
functional as I am writing this (kernel-xen-2.6.19-1.2911.fc6).

According to Intel documentation, the i965 family uses system memory for the 
graphics adapter so, since this host has 4 GB, I tried booting with mem=3G 
like this:

title Fedora Core (2.6.19-1.2911.fc6xen)
        root (hd0,0)
        kernel /xen.gz-2.6.19-1.2911.fc6
        module /vmlinuz-2.6.19-1.2911.fc6xen ro root=/dev/sys_vg/root_lv 
all-generic-ide quiet mem=3G
        module /initrd-2.6.19-1.2911.fc6xen.img

which apparently fixed the display corruption problem.

Comment 2 Davide Bolcioni 2007-02-21 13:48:59 UTC
Typing in a terminal and running glxgears apparently worked OK also using said 
workaround.

Comment 3 Davide Bolcioni 2007-02-22 17:03:37 UTC
However, attempts to create a new fully virtualized Xen image consistently 
produce display corruption and lock up the host.

Comment 5 Red Hat Bugzilla 2007-07-25 01:38:27 UTC
change QA contact

Comment 7 Chris Lalancette 2008-02-26 23:56:04 UTC
This report targets FC6, which is now end-of-life.

Please re-test against Fedora 7 or later, and if the issue persists, open a new bug.

Thanks



Note You need to log in before you can comment on or make changes to this bug.