Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229475 - File::writable? gives incorrect result if process changes euid/egid
Summary: File::writable? gives incorrect result if process changes euid/egid
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Bill Huang
URL:
Whiteboard:
Depends On: 222177
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-21 13:12 UTC by Akira TAGOH
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-30 11:28:41 UTC


Attachments (Terms of Use)

Description Akira TAGOH 2007-02-21 13:12:52 UTC
+++ This bug was initially created as a clone of Bug #222177 +++

When a ruby script running as root changes euid/egid, the results of
File::writable?(f) and File::stat(f).writable? will differ because one uses
glibc's eaccess while the other doesn't (and File::writable? is wrong). The
attached program demonstrates the problem.

This bug is ultimately caused by a bug in glibc's eaccess
(http://sourceware.org/bugzilla/show_bug.cgi?id=3846) but it's a separate
regression in ruby-1.8.5 (compared to earlier versions of the ruby RPM) since
the ruby-1.8.5 rpm's now use eaccess where older ones used ruby's own code to
simulate eaccess.

A simple fix would be to build ruby w/o HAVE_EACCESS as it has been build in the
past until the glibc bug is fixed.

-- Additional comment from dlutter@redhat.com on 2007-01-10 14:09 EST --
Created an attachment (id=145276)
Ruby script demonstrating the problem (run as root)

Comment 1 Akira TAGOH 2007-03-30 11:28:41 UTC
seems like got fixed in rawhide. it works fine now.


Note You need to log in before you can comment on or make changes to this bug.