Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229433 - need to update forcedeth driver for MCP55 platforms
Summary: need to update forcedeth driver for MCP55 platforms
Keywords:
Status: CLOSED DUPLICATE of bug 197797
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Andy Gospodarek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-21 00:57 UTC by Hans-Helmar Althaus
Modified: 2014-06-29 22:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-14 18:40:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Hans-Helmar Althaus 2007-02-21 00:57:00 UTC
Description of problem:

the forcedeth driver you are using in rhel4 fails to
setup link on most gigabit switches

Version-Release number of selected component (if applicable):

2.6.9-42 with forcedeth 0.41

How reproducible:

Connect for example a hp xw9400 on a hp procurve switch
  
Actual results:

no traffic

Expected results:

normal communication

Additional info:

the link light will go on, but the
RX counter remains on zero

the current driver aviable from nvidia
or plain vamilla kernel works.

Comment 1 Andy Gospodarek 2007-03-12 21:37:15 UTC
I have an xw9300 and tested it today without any problems.  Can you send output
from 'ethtool ethX' for that interface?

A sysreport might be nice as well, but we can start with the ethtool output if
you like.

Comment 2 Hans-Helmar Althaus 2007-03-13 07:51:02 UTC
I am sorry i have installed the driver provided from nvidia because we need this
machine working. With this driver or attached on a 100 MBit ethernet i did never
see any problems for now. The problem for me is that i have to hack the
redhat.initrd for pxe-installation of this workstation (i have to unpack the
initrd and to replace forcedeth module). The problem is known to nvidia and hp
(xw9400 and maybe also fujtsu-siemens v840) - please ask anybody there if you
dont trust me, i can provide you a contact person if you like.

The output of ethtool (eth0 is a nvidia interface but the driver is the on from
nvidia webside, forcedeth 0.59 !! ):

[root@fsc-amd-2 ~]# ethtool eth0
Settings for eth0:
        Supported ports: [ MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: externel
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Link detected: yes


Comment 3 Andy Gospodarek 2007-03-13 13:05:56 UTC
Thanks for the feedback.  Please send me your contact person at HP, so I can get
more detail about which switches have this problem.

I have not heard complaints about the xw9400 and forcedeth on 4.4 and I've not
personally experienced and problems with my xw9400 and an unmanaged D-Link
gigabit switch, so I would like to understand what devices won't link up with
this hardware.

Comment 4 Andy Gospodarek 2007-03-14 18:40:18 UTC
Good news.  I played around some more and noticed that eth0 does have problems
linking up at gigabit speeds and confirmed that this is fixed in our latest
development kernels (though I did find another problem).  

Closing this as a duplicate of BZ 197797.

*** This bug has been marked as a duplicate of 197797 ***


Note You need to log in before you can comment on or make changes to this bug.