Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229427 - authconfig allows ldap authentication when user information from ldap is enabled
Summary: authconfig allows ldap authentication when user information from ldap is enabled
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-20 23:02 UTC by Kimmo Vuorinen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-21 09:07:35 UTC


Attachments (Terms of Use)

Description Kimmo Vuorinen 2007-02-20 23:02:51 UTC
Description of problem:
authconfig allows authentication from ldap when user information from ldap is
enabled.

Steps to Reproduce:
1. run authconfig-tui, enable ldap user information, make sure ldap
authentication is disabled, save settings
2. log in using an account from ldap-database
  
Actual results:
Login is successful

Expected results:
Login fails, but uid/user gid/group mapping etc. from ldap-database is still
available when required

Comment 1 Tomas Mraz 2007-02-21 09:07:35 UTC
That's a feature, not a bug, of having full accounts including passwd hash in
LDAP database. 

You can remove ldap from 'shadow:' line of /etc/nsswitch.conf however doing this
change in authconfig in general is not desirable.



Note You need to log in before you can comment on or make changes to this bug.