Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229409 - Print.h missing in /usr/include/X11/extensions/
Summary: Print.h missing in /usr/include/X11/extensions/
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-proto-devel
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-20 21:00 UTC by Eric Majzoub
Modified: 2018-04-11 11:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-28 16:24:23 UTC


Attachments (Terms of Use)

Description Eric Majzoub 2007-02-20 21:00:39 UTC
Description of problem:

FC6 is missing:
/usr/include/X11/extensions/Print.h

Causes problems compiling programs using the OpenMotif and/or Lesstif API.

Version-Release number of selected component (if applicable):

Xorg version 7.1 shipping with FC6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I submitted this as a bug at the request of the maintainer of the plotting
program XMGrace.

Comment 1 Adam Jackson 2007-02-28 16:24:23 UTC
The Xprint support is deprecated.  The extension headers are available in
libXp-devel if you really need them, but since most modern linux systems do not
ship an Xprint server applications are encouraged to find other solutions for
printing.

'yum install /usr/include/X11/extensions/Print.h' would have found that package
for you, btw.

Comment 2 Wharton Sinkler 2011-10-19 14:01:04 UTC
I am encountering the same problem, trying to install openmotif 2.3.1 on Red Hat Enterprise Linux Server 5.6 (Tikanga).  

Compilation fails because /usr/include/X11/extensions/Print.h is included in the Xm.h header file for Motif.  

I also cannot use 'yum install ...' because that reports that Print.h is not available, possibly because RHN support is not registered (not even sure what this is but found somewhere that it needs to be registered at the time the system is set up, which is too late now).  

Any ideas how I can move forward on installing openmotif (get around this missing file issue)?  

Thanks,
Wharton


Note You need to log in before you can comment on or make changes to this bug.