Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229354 - Motif pull-down menus don't draw correctly with Xnest
Summary: Motif pull-down menus don't draw correctly with Xnest
Keywords:
Status: CLOSED DUPLICATE of bug 229350
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-20 15:58 UTC by Esteban Xandri
Modified: 2018-04-11 14:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-20 16:10:19 UTC


Attachments (Terms of Use)

Description Esteban Xandri 2007-02-20 15:58:04 UTC
Description of problem:
Menu items of motif apps, do not display correctly in an Xnest window.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xnest-1.1.1-47.5

How reproducible:
Always

Steps to Reproduce:
1.Xnest -ac :1 &
2.twm -display :1 (also on other window managers such as kdm and xfwm4)
3.run any motif app
  
Actual results:
Some expected menu items are invisible. After a few clicks on missing items 
locations they appear (sometimes)

Expected results:
Proper display of pull-down menus


Additional info:
This behaviour has been reported in OpenSolaris bug database with Bug id 
6366490 (http://bugs.opensolaris.org/bugdatabase/view_bug.do?bug_id=6366490)
Sun has recently released a patch fixing it
I could also verify that this problem is not present if Xvnc is used instead of 
Xnest

Comment 1 Esteban Xandri 2007-02-20 16:10:19 UTC
This buga has been reported by mistake, it's a duplicate of Bug 229350

Comment 2 Matěj Cepl 2007-02-28 08:17:40 UTC

*** This bug has been marked as a duplicate of 229350 ***


Note You need to log in before you can comment on or make changes to this bug.