Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229353 - missing updates.img kills install via rescue CD-ROM
Summary: missing updates.img kills install via rescue CD-ROM
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-20 15:57 UTC by John Reiser
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-26 21:55:53 UTC


Attachments (Terms of Use)

Description John Reiser 2007-02-20 15:57:55 UTC
Description of problem: Attempting to install from the rescue CD-ROM fails
because a missing core/development/i386/os/images/updates.img triggers the
failure to find stage2.img, even though stage2.img is there.


Version-Release number of selected component (if applicable):
fe1a3303743e05feaca73cd2d81211b2  FC-development-i386-rescuecd.iso   [md5sum;
2007-02-20]

How reproducible: always


Steps to Reproduce:
1. boot rescue CD-ROM
2. specify language, keyboard, http, ipv4+dhcp, no ipv6, mirror name+directory
3. wait
  
Actual results: a wait of several minutes with no feedback, then "Unable to
retrieve
http://fedora.cat.pdx.edu//linux/core/development/i386/os/images/stage2.img"
even though it is there and can be retrieved by firefox from a running system.


Expected results: installation proceeds


Additional info:

Comment 1 Jeremy Katz 2007-02-26 19:51:21 UTC
Can you still hit this?  If so, can you hit it, then put an updates.img there
and get /tmp/anaconda.log for us to look at?  

Comment 2 John Reiser 2007-02-26 20:33:24 UTC
Where should I get an updates.img, or how should I create one?

I am downloading the latest i386 rescue CD-ROM (Sunday 2007-02-25) to try it.

Comment 3 Jeremy Katz 2007-02-26 20:35:52 UTC
Should be able to just create an empty ext2 image.
  dd if=/dev/zero of=updates.img bs=72k count=20
  mke2fs updates.img


Comment 4 John Reiser 2007-02-26 21:55:53 UTC
No, I cannot trigger the error using 708f5eddd5323b05588487f2473be17f06ac0b57 
FC-development-i386-rescuecd.iso  [sha1sum, 2007-02-25]

However, I did notice a couple things about rescue CD.  Probably this original
bugzilla report was the result of using a truncated CD-RW: only the first 9MB or
so (10% of 90MB) was correct; the rest probably was omitted due to error in
writing a CD-RW; but the CD-RW had been used successfully as a rescue CD before,
so it looked OK.  So: the rescue CD-ROM should have an option for mediacheck!
Even with a correct CD platter, bug #229099 (weird network trouble with nVidia
nForce4 forcedth) causes behavior that is not obvious.

With the truncated CD, the specific messages on Alt-F3 console are:
-----
trying to mount CD device scd0
mntloop loop0 on /mnt/runtime as /mnt/source/images/stage2.img fd is 10
failed to mount loop: Invalid argument
mouting stage2 failed
transferring http://fedora.cat.pdx.edu// ... /updates.img to a fd
cannot determine address family of fedora.cat.pdx.edu
we don't have reverse DNS for ipv6 yet
transferring http://fedora.cat.pdx.edu// ... /disk1/images/updates.img to a fd
<no response>
-----
and the log on Alt-F4 console is
-----
<3> cramfs: wrong magic
-----


With the full verified CD, but with bug #229099 [network hosed] acting up, the
message is:
-----
CRITICAL: IOError 4 occurred getting
http://fedora.cat.pdx.edu/linux/core/development/i386/os/RELEASE-NOTES-en_US.UTF-8
-----



Note You need to log in before you can comment on or make changes to this bug.