Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229352 - [PATCH] Eclipse AutoTools plugin CVS does not build with cdt 3.1.2
Summary: [PATCH] Eclipse AutoTools plugin CVS does not build with cdt 3.1.2
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-20 15:50 UTC by Jordy Potman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-20 17:25:59 UTC


Attachments (Terms of Use)
Patch to fix bug described above (deleted)
2007-02-20 15:50 UTC, Jordy Potman
no flags Details | Diff

Description Jordy Potman 2007-02-20 15:50:45 UTC
The CVS version of the Eclipse AutoTools plugin does not build with the recently
released CDT 3.1.2. This is caused by the changes to
/src/org/eclipse/cdt/make/internal/ui/editor/MakefileSourceConfiguration.java in
Eclipse org.eclipse.cdt-build/org.eclipse.cdt.make.ui CVS Revision 1.14.2.1

The attached patch changes AutomakefileSourceConfiguration.java and
AutomakeEditor.java to build with the newer version of
MakefileSourceConfiguration.java

Comment 1 Jordy Potman 2007-02-20 15:50:46 UTC
Created attachment 148417 [details]
Patch to fix bug described above

Comment 2 Andrew Overholt 2007-02-20 16:17:54 UTC
Thanks for the patch, Jordy!  I'll apply it today and close this bug when it is.

Comment 3 Andrew Overholt 2007-02-20 17:25:07 UTC
Committed.  Thanks again, Jordy.

One thing this means is that HEAD won't work against our eclipse-cdt packages, but I assume Jeff will be bumping those to 3.1.2 once the Eclipse SDK moves to 3.2.2.  Hopefully that will be within the next day or so.

ChangeLog entry:

2007-02-20  Andrew Overholt  <overholt@redhat.com>

	Patch from Jordy Potman
	http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=229352

	* src/com/redhat/eclipse/cdt/autotools/editors/automake/AutomakefileSourceConfiguration.java
	(AutomakefileSourceConfiguration): Update super constructor call to reflect
	change in CDT 3.1.2.
	* src/com/redhat/eclipse/cdt/autotools/editors/automake/AutomakeEditor.java
	(initializeEditor): Likewise.



Note You need to log in before you can comment on or make changes to this bug.