Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229351 - no feedback during long discovery of host name and domain
Summary: no feedback during long discovery of host name and domain
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-20 15:47 UTC by John Reiser
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-27 15:08:38 UTC


Attachments (Terms of Use)

Description John Reiser 2007-02-20 15:47:54 UTC
Description of problem: There is no feedback during the two-minute wait for
"Determining host name and domain" on install via http+ipv4+dhcp when booted
from diskboot.img.  The user may well give up too soon.


Version-Release number of selected component (if applicable):
d75d44862eb9bf5ca0299932f0ad43f3  diskboot.img   [md5sum;
core/development/i386/os/images 2007-02-20]


How reproducible:
always


Steps to Reproduce:
1. boot diskboot.img
2. specify language, keyboard, http, enable ipv4+dhcp, disable ipv6
3.
  
Actual results: 2-minute wait with no feedback for "Determining host name and
domain" on consumer-grade network with dhcp server only (no dns server, but yes
dns ipv4 address is given).


Expected results: Warn that the timeout is 2 minutes; also give feedback (every
5 seconds or so) to say that there has been no crash.


Additional info:  <Alt>F3 shows that there was immediate response to dhcp lease,
subnet-mask, broadcast, and option routers; but no indication of any problem
after that.

Comment 1 David Cantrell 2007-03-26 16:08:40 UTC
I'm pretty sure this is a dupe of bug #230941.  DHCPv6 was still being run even
if you disabled it, which made the host discovery appear to take forever because
of the DHCPv6 timeout.  This has been fixed in rawhide and now the host
discovery part you mention quickly resolves and no longer appears hung.

Can you try rawhide to see if it's still exhibiting the behaviour you describe?

Comment 2 John Reiser 2007-03-27 03:03:50 UTC
Fixed in diskboot.img of 2007-03-26 for i386 with sha1sum:
42cb7578571eb2f51815eef7f942bbb1ed7a9777  diskboot.img
The wait was just a couple seconds when enable ipv4+dhcp, disable ipv6.


Comment 3 David Cantrell 2007-03-27 15:08:38 UTC
Thanks.  Closing per comment #2.


Note You need to log in before you can comment on or make changes to this bug.