Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229312 - RFE: add BR's for extra plugins once FE-FC merge is done
Summary: RFE: add BR's for extra plugins once FE-FC merge is done
Keywords:
Status: CLOSED DUPLICATE of bug 136268
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-02-20 08:16 UTC by Alex Lancaster
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-04 16:42:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 401782 None None None Never

Description Alex Lancaster 2007-02-20 08:16:16 UTC
Description of problem:
Retagging in rhythmbox fails silently because gstreamer-plugins-good not built
against taglib.  Current rhythmbox is built with retagging support, but can't
make use of retagging for some audio formats (such as mp3) because it isn't
built against taglib.

Version-Release number of selected component (if applicable):
gstreamer-plugins-base-0.10.10-1.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Import a track in mp3 format.
2. Try retagging

Actual results:
Get error from gstreamer:

"Error saving song information: Internal GStreamer problem; file a bug"

Expected results:
Tags should be changed.

Additional info:
See upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=401782

taglib is not in Core, which probably accounts for the fact that this is not
built against it.  Hopefully this will go away with the Core + Extras merge.

Comment 1 Bastien Nocera 2007-04-01 14:08:25 UTC
Marking as a devel bug.

Comment 2 Hans de Goede 2007-04-03 08:32:18 UTC
I was doing some gstreamer debugging and because of that rebuild
gstreamer-plugins-good, this caused me to notice that when building on my system
several extra plugins get build.

Once its possible to build core packages against extras packages, can you please
add the following BuildRequires (and the new plugins to the %files list):
taglib-devel
libcdio-devel

And maybe even (perhaps in in an gstreamer-plugins-good-extras subpackage):
aalib-devel


Comment 3 Adam Jackson 2007-04-04 16:42:58 UTC

*** This bug has been marked as a duplicate of 136268 ***


Note You need to log in before you can comment on or make changes to this bug.