Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229248 - "service crond reload" isn't functional and should be removed
Summary: "service crond reload" isn't functional and should be removed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anacron
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-19 19:10 UTC by Dave Ludlow
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-04 14:45:32 UTC


Attachments (Terms of Use)
Patch to remove "reload" option from service file (deleted)
2007-02-19 19:10 UTC, Dave Ludlow
no flags Details | Diff

Description Dave Ludlow 2007-02-19 19:10:32 UTC
Description of problem:
When executing "service crond reload" it responds ""Reloading cron daemon
configuration: " and then sends a HUP signal to the crond daemon.  The problem
is that the crond daemon doesn't reload it's configuration upon receiving HUP as
many daemons do.  It's man page states that it closes and reopens it's log files
instead.

Version-Release number of selected component (if applicable):
2.3-44.fc6

How reproducible:
Every time

Steps to Reproduce:
1. Add a line like "* * * * * root /bin/touch /tmp/foo" to /etc/crontab.
2. Execute "service crond reload".
3. Wait a minute.
4. Look for /tmp/foo file - it never gets created.
5. Execute "service crond restart".
6. Wait a minute.
7. Look for /tmp/foo file - now it's there.

Actual results:
/tmp/foo is not created unless crond is restarted.

Expected results:
/tmp/foo gets created within a minute

Additional info:
Since there is no signal that will cause crond to reload its configuration, the
reload command cannot be made to work without making it a redundant version of
the restart command.  Suggest simply removing the reload command.

Removing this might break scripts that depend on it - but those scripts weren't
working anyway.

Comment 1 Dave Ludlow 2007-02-19 19:10:32 UTC
Created attachment 148358 [details]
Patch to remove "reload" option from service file

Comment 2 Marcela Mašláňová 2007-03-13 11:08:40 UTC
I had similar problem in devel. I added some patches from devel to FC-6 last
week, so try update and let me know. I try it and works for me.
The problem was proper reading jobs from all queries.

Comment 3 Marcela Mašláňová 2007-04-04 14:45:32 UTC
Use standart paths like /etc/cron.* or use crontab -e.

/etc/crontab is part of package crontabs and his primary use isn't scheduling
jobs as you've mentioned.


Note You need to log in before you can comment on or make changes to this bug.