Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229209 - Strange behaviour when pasting texts into vi/vim
Summary: Strange behaviour when pasting texts into vi/vim
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-19 16:12 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-19 16:40:12 UTC


Attachments (Terms of Use)

Description Robert Scheck 2007-02-19 16:12:53 UTC
Description of problem:
Since a view patch levels in vim there's a strange behaviour when pasting
texts into vi/vim: Once a line contains a comment marker, any following lines 
are commented - even if they've their own comment marker in the beginning. 

Simple example would be mark some parts with comments of /etc/vimrc and paste 
into after. Or go to a line with a comment mark, switch into insert mode and 
press enter key, the comment mark will be used as prefix for the next line.

Version-Release number of selected component (if applicable):
vim-7.0.192-1

How reproducible:
Everytime, see above.

Actual results:
Strange behaviour when pasting texts into vi/vim

Expected results:
Normal behaviour like in the past? :)

Comment 1 Karsten Hopp 2007-02-19 16:40:12 UTC
That's what :set paste is for. This avoids any unwanted identing or autocomments
when you copy and paste stuff.

Comment 2 Robert Scheck 2007-02-19 16:53:22 UTC
But why are you changing the default?

Comment 3 Karsten Hopp 2007-02-20 09:50:13 UTC
due to en error on my side filetype plugins had been disabled, that's what has
been fixed in the latest releases. Please disable that in /etc/vimrc if you
don't like it.


Note You need to log in before you can comment on or make changes to this bug.