Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229181 - HTTP install from a 'numbered' directory causes numeric increment in directory name for some packages
Summary: HTTP install from a 'numbered' directory causes numeric increment in director...
Keywords:
Status: CLOSED DUPLICATE of bug 225086
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-19 12:29 UTC by Ben
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-23 18:30:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
HTTPD access log of the RHEL 5 beta 2 installer requesting packages from the wrong place (deleted)
2007-02-19 12:29 UTC, Ben
no flags Details

Description Ben 2007-02-19 12:29:38 UTC
Description of problem:

Installing manually via HTTP from a URL of the form
http://<server>/redhat/RHEL5/ (with Server/ beneath that) I found at least 1250
packages (in the install type I was doing) which the installer seemed to be
trying to download from [...]/RHEL6/ instead.  Initially I thought this was just
for RPMs with fc6 in the filename.  But apparently not.


Version-Release number of selected component (if applicable):

RHEL 5 beta 2.  Serving Apache is httpd-2.0.52-28 from a RHEL 4 box.


How reproducible:

Every time, for me anyway!


Steps to Reproduce:
1. Copy contents of RHEL 5 beta 2 ISOs to a web-accessible directory called
"RHEL5" with /Server/ beneath it.
2. Install from USB key using the vmlinuz and initrd.img from Disk 1's
images/pxeboot/ directory.
3. Point installer at URL in 1.
4. Choose any kind of package selection which includes the packages listed in
the attached file.


Actual results:

Failure to install those packages until a symlink from RHEL5 to RHEL6 was
created.  Install then proceeded as normal.

Expected results:

Not to fail on asking for those packages.  To continue to ask for packages from
the correct directory.


Additional info:

Dunno.  Seems to work perfectly when there's no number in the directory, i.e.
http://<server>/redhat/RHbeta/

Weird huh?

Comment 1 Ben 2007-02-19 12:29:38 UTC
Created attachment 148316 [details]
HTTPD access log of the RHEL 5 beta 2 installer requesting packages from the wrong place

Comment 2 David Cantrell 2007-02-26 22:38:07 UTC
Not really that weird [to me] as I added code to handle people installing from
an http server with disc# directories.  On failure, I would increment the number
and try again.  We've fixed some of this (if not all in rawhide), so it
shouldn't be too much of a problem to fix.

Comment 3 David Timms 2007-04-05 23:53:33 UTC
Seems to be a dupe of bug 225086

Comment 4 David Cantrell 2007-08-23 18:30:42 UTC

*** This bug has been marked as a duplicate of 225086 ***


Note You need to log in before you can comment on or make changes to this bug.