Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229165 - Enable xft support for emacs
Summary: Enable xft support for emacs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Chip Coldwell
QA Contact:
URL:
Whiteboard:
: 231769 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-19 03:12 UTC by Stephen
Modified: 2018-04-11 09:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-22 17:07:16 UTC


Attachments (Terms of Use)

Description Stephen 2007-02-19 03:12:54 UTC
Please configure emacs with the additional options:

  --enable-font-backend --with-xft

to enable true type font support.

The new font backend is only enabled if emacs is started as:

  emacs --enable-font-backend

So should be safe.

Comment 1 Alexandre Oliva 2007-02-19 07:47:23 UTC
Is this about xemacs?  I don't see any such options in GNU emacs' configure
script sources or documentation.

Comment 2 Stephen 2007-02-19 14:18:39 UTC
I think this should be available in the new emacs 22 (as shipped in rawhide).

http://www.emacswiki.org/cgi-bin/wiki/XftGnuEmacs

Did I get this wrong? Has this feature been bumped to emacs 23?


Comment 3 dann 2007-02-22 16:41:04 UTC
(In reply to comment #2)
> I think this should be available in the new emacs 22 (as shipped in rawhide).

No, it is not. Emacs-23 will have it after the emacs-unicode-2 branch will be
merged to emacs mainline... 




Comment 4 Stephen 2007-02-22 17:07:16 UTC
OK. Waiting for emacs 23...

Comment 5 Bill Nottingham 2007-03-02 17:45:34 UTC
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.

Comment 6 Chip Coldwell 2007-03-12 14:11:09 UTC
*** Bug 231769 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.