Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229161 - dmraid stopped from working after changing kernel to kernel-xen
Summary: dmraid stopped from working after changing kernel to kernel-xen
Keywords:
Status: CLOSED DUPLICATE of bug 196828
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-19 01:42 UTC by Jarkko
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-25 11:11:23 UTC


Attachments (Terms of Use)

Description Jarkko 2007-02-19 01:42:55 UTC
Description of problem: dmraid stopped from working after changing kernel to
kernel-xen. Worked with Fedora 7 Test1 kernel.

Version-Release number of selected component (if applicable):
kernel-xen-2.6.19-1.2898.2.3.fc7

How reproducible: Always (done twise).

Steps to Reproduce:
1. get Fedora 7 Test1 CD
2. install using dmraid
3. yum install kernel-xen + reboot using the xen kernel
  
Actual results: /dev/mapper/ does not contain the raid devices anymore.

Expected results: /dev/mapper/ should continue to contain the raid devices.

Additional info: I _only_ changed kernel to kernel-xen, so I am 100% sure that
"yum install kernel-xen" broke this.

Comment 1 Jarkko 2007-02-19 01:48:44 UTC
- Working kernel: kernel-2.6.19-1.2914.fc7

- Same issue happens also with: kernel-2.6.20-1.2932.fc7 (see bug #229158)

Comment 2 Jarkko 2007-02-25 10:45:46 UTC
I extracted /boot/initrd-2.6.19-1.2898.2.3.fc7xen.img and added to "init":

-------------------------------------------------------------------------------
rmparts sdb
rmparts sda
dm create ddf1_4c534920202020201000005500000000330a535300000a28 0 974608384
mirror core 2 131072 nosync 2 8:0 0 8:16 0
dm partadd ddf1_4c534920202020201000005500000000330a535300000a28
-------------------------------------------------------------------------------

...between lines "mkblkdevs" and "resume LABEL=swap".

Then I replaced /boot/initrd-2.6.19-1.2898.2.3.fc7xen.img with my modified
version and rebooted with 2.6.19-1.2898.2.3.fc7.

It is working. :)

So... I'm not sure _where_ the bug is, but now we know _what_ happens. The
problem is: dm related lines are missing from initrd after running mkinitrd with
kernel-xen-2.6.19-1.2898.2.3.fc7 and kernel-2.6.20-1.2932.fc7 up to
kernel-2.6.20-1.2942.fc7.

Comment 3 Jarkko 2007-02-25 11:11:23 UTC

*** This bug has been marked as a duplicate of 196828 ***


Note You need to log in before you can comment on or make changes to this bug.