Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229158 - dmraid stopped from working after kernel upgrade
Summary: dmraid stopped from working after kernel upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 196828
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-19 01:08 UTC by Jarkko
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-25 11:07:42 UTC


Attachments (Terms of Use)

Description Jarkko 2007-02-19 01:08:03 UTC
Description of problem: dmraid stopped from working after kernel upgrade. Worked
with Fedora 7 Test1 kernel. 

Version-Release number of selected component (if applicable):
kernel-2.6.20-1.2932.fc7

How reproducible: Always (done twise).

Steps to Reproduce:
1. get Fedora 7 Test1 CD
2. install using dmraid
3. yum upgrade kernel + reboot
  
Actual results: /dev/mapper/ does not contain the raid devices anymore.

Expected results: /dev/mapper/ should continue to contain the raid devices.

Additional info: I _only_ updated the kernel package, so I am 100% sure that
"yum upgrade kernel" broke this.

Comment 1 Jarkko 2007-02-19 01:48:07 UTC
- Working kernel: kernel-2.6.19-1.2914.fc7

- Same issue happens also with: kernel-xen-2.6.19-1.2898.2.3.fc7 (see bug #229161)

Comment 2 Jarkko 2007-02-21 21:32:02 UTC
The currently latest kernel-2.6.20-1.2936.fc7 doesn't work either.

Comment 3 Jarkko 2007-02-24 03:04:24 UTC
The currently latest kernel-2.6.20-1.2940.fc7 doesn't work either.

Comment 4 Jarkko 2007-02-24 16:52:12 UTC
The currently latest kernel-2.6.20-1.2942.fc7 doesn't work either.

Comment 5 Jarkko 2007-02-24 20:33:54 UTC
I extracted the initrd images and compared them. The cause for this problem has
been found:

--- initrd-2.6.19-1.2914.fc7/init       2007-02-24 22:19:23.000000000 +0200
+++ initrd-2.6.20-1.2942.fc7/init       2007-02-24 22:19:43.000000000 +0200
@@ -76,10 +76,7 @@
 echo "Loading dm-snapshot.ko module"
 insmod /lib/dm-snapshot.ko
 mkblkdevs
-rmparts sdb
-rmparts sda
-dm create ddf1_4c534920202020201000005500000000330a535300000a28 0 974608384
mirror core 2 131072 nosync 2 8:0 0 8:16 0
-dm partadd ddf1_4c534920202020201000005500000000330a535300000a28
+resume LABEL=swap
 echo Creating root device.
 mkrootdev -t ext3 -o defaults,ro dm-2
 echo Mounting root filesystem.

Comment 6 Jarkko 2007-02-25 11:07:42 UTC

*** This bug has been marked as a duplicate of 196828 ***


Note You need to log in before you can comment on or make changes to this bug.