Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229151 - tail command doesn't support +n parameter.
Summary: tail command doesn't support +n parameter.
Keywords:
Status: CLOSED DUPLICATE of bug 173431
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-18 19:38 UTC by Serge Dubrouski
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-19 09:36:50 UTC


Attachments (Terms of Use)

Description Serge Dubrouski 2007-02-18 19:38:57 UTC
tail utility doesn't support +n parameters. For example:

on Fedora 5 and 6:

$ cat /etc/group | tail +3
tail: cannot open `+3' for reading: No such file or directory

On CentOS 4.3, Solaris, etc...

[sdubrov@home ~]$ tail /etc/group | tail +3
torrent:x:101:
hacluster:x:501:
haclient:x:502:

This is a quote from man page:

If the first character of N (the number of bytes or lines) is  a  ‘+’,
print  beginning with the Nth item from the start of each file, other-
wise, print the last N items in the file.  N  may  have  a  multiplier
suffix: b 512, k 1024, m 1024*1024.

Comment 1 Tim Waugh 2007-02-19 09:36:50 UTC
That 'N' comes from this:

  -n, --lines=N

so you need:  tail -n +5
or: tail --lines=+5


*** This bug has been marked as a duplicate of 173431 ***


Note You need to log in before you can comment on or make changes to this bug.