Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229136 - Screen Resolution not correct
Summary: Screen Resolution not correct
Keywords:
Status: CLOSED DUPLICATE of bug 231359
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-18 02:12 UTC by Larry K. Brown
Modified: 2018-04-11 07:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 21:52:37 UTC


Attachments (Terms of Use)
xorg file (deleted)
2007-03-09 21:24 UTC, Larry K. Brown
no flags Details
xorg log file (deleted)
2007-03-09 21:25 UTC, Larry K. Brown
no flags Details

Description Larry K. Brown 2007-02-18 02:12:48 UTC
Description of problem:
The screen resolution is limited to 640 or 800 in the menus
Previous versions of FC had additional menu preferences that required
root access but let you manually specify the correct hardware.

Version-Release number of selected component (if applicable):


How reproducible:
Installed on Emachine T3508 computer with defaults

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 cje 2007-03-02 17:36:17 UTC
i've had this problem too on an old toshiba portege 2000 laptop.  the screen
settings weren't detected so it only offered 800x600 or 640x480 even though it
knows the LCD panel is 1024x768.

got this in the Xorg.0.log file:

(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/lib/xorg/modules//libddc.so
(II) Module ddc: vendor="X.Org Foundation"
	compiled for 7.2.0, module version = 1.0.0
	ABI class: X.Org Video Driver, version 1.0
f000:36ec: 01 ILLEGAL EXTENDED X86 OPCODE!
(II) TRIDENT(0): VESA VBE DDC not supported

the tool is system-config-display and it just isn't installed by default
anymore.   (i can't guarantee it was installed by default on FC6)

yum install system-config-display

(or find it in 'add/remove software' if that's working today  ;-))

it also installed xsri (whatever that is) on my system.

Comment 2 Bill Nottingham 2007-03-02 17:42:39 UTC
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.

Comment 3 Matěj Cepl 2007-03-08 23:45:53 UTC
cje, please, read the text below (I will need the same information from you),
and please file a separate bug for your issue -- we are not able to deal with
multiple issues in one report.

Reporter, thanks for the bug report.  We have reviewed the information you have
provided above, and there is some additional information we require that will be
helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.


Comment 4 Larry K. Brown 2007-03-09 21:24:05 UTC
Created attachment 149741 [details]
xorg file

Comment 5 Larry K. Brown 2007-03-09 21:25:34 UTC
Created attachment 149742 [details]
xorg log file

Comment 6 Adam Jackson 2007-03-12 16:10:08 UTC
Blah.  Maybe we should force LVDS on for xpress200.

Comment 7 Adam Jackson 2007-04-02 21:52:37 UTC

*** This bug has been marked as a duplicate of 231359 ***


Note You need to log in before you can comment on or make changes to this bug.