Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229125 - ati proprietary driver not working with kernel when dri enabled
Summary: ati proprietary driver not working with kernel when dri enabled
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-17 17:21 UTC by tjustt
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-21 22:29:43 UTC


Attachments (Terms of Use)
xorg.conf (deleted)
2007-02-17 17:26 UTC, tjustt
no flags Details
xorg.conf in text (deleted)
2007-02-17 17:36 UTC, tjustt
no flags Details

Description tjustt 2007-02-17 17:21:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.1) Gecko/20070209 Firefox/2.0.0.1

Description of problem:
I can't get the ati proprietary linux driver (8.33.6) to work if i have enabled dri in my xorg.conf, i can't even get to login screen because there is no signal to screen after loading the system, even Ctrl+Alt+F1 can't start the text interface (but it can be loaded because i can restart my system with Ctrl+Alt+Esc). 

This problem has occur after updating my kernel to 2.6.20-1.2930 and with 2.6.20-1.2932 versions but it works with 2.6.20-1.2925 and after updating i installed the correct fglrx module for my kernel.

I used the installer from http://www.michaellarabel.com/?k=blog&i=33 to generate the ati driver installation packages.

Version-Release number of selected component (if applicable):
kernel - 2.6.20-1.2932 and 2.6.20-1.2930

How reproducible:
Always


Steps to Reproduce:
1. Generate ati proprietary drivers with Michael Larabels installer

2. Install generated packages

3. Configure dri to be loaded with system start in xorg.conf

3. Reboot my system

Actual Results:


Expected Results:


Additional info:
My graphics card RX850 XT PL

Comment 1 tjustt 2007-02-17 17:26:14 UTC
Created attachment 148271 [details]
xorg.conf

How DRI is enabled

Comment 2 tjustt 2007-02-17 17:32:44 UTC
Sorry forgot to add that when i disabled DRI, i could normally start my system. 

Comment 3 tjustt 2007-02-17 17:36:09 UTC
Created attachment 148273 [details]
xorg.conf in text

Comment 4 Dave Jones 2007-02-21 22:29:43 UTC
report problems with proprietary modules to their vendors. we can't fix them.

Comment 5 Bill Nottingham 2007-03-02 17:37:24 UTC
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.


Note You need to log in before you can comment on or make changes to this bug.