Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229118 - "Preferred Applications" applet lacks alternative items
Summary: "Preferred Applications" applet lacks alternative items
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-17 14:11 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-03 16:41:35 UTC


Attachments (Terms of Use)
Screenshot of "Preferred Applications" applet for a new user (deleted)
2007-02-17 14:13 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2007-02-17 14:11:57 UTC
Description of problem:
After a fresh install from the "FC Development" tree and logging into
a new account, the "Preferred Applications" applet does not offer any
alternatives to the default selections, e.g., there is only "firefox"
present as "Web Browser" application. Both "elinks" and "epiphany" are
not included albeit being installed.

Version-Release number of selected component (if applicable):
control-center-2.17.91-2.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Log in to fresh account.
2. Open "Preferred Applications" aplet.
3. Try to change the default "Web Browser" application.
  
Actual results:
None, because "firefox" is the only item.

Expected results:
All installed browsers are listed, and the preferred browser can be
chosen.

Additional info:
Launching "gnome-default-applications-properties" from the command line
leads to a warning, namely:

 'I/O warning : failed to load external entity
  "./gnome-default-applications.xml"'

It seems like a path has not been set correctly during the "configure"
stage.

Comment 1 Joachim Frieben 2007-02-17 14:13:53 UTC
Created attachment 148269 [details]
Screenshot of "Preferred Applications" applet for a new user

Comment 2 Joachim Frieben 2007-03-03 16:40:45 UTC
Fixed in "control-center-2.17.92-1.fc7".


Note You need to log in before you can comment on or make changes to this bug.