Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229029 - Downgrade to 0.6.4 breaks new configuration options
Summary: Downgrade to 0.6.4 breaks new configuration options
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc
Version: 6
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-16 17:02 UTC by Stefan Becker
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-18 08:25:15 UTC


Attachments (Terms of Use)

Description Stefan Becker 2007-02-16 17:02:22 UTC
Description of problem:

The previous version 0.7.0 was added support for Rekeying and NAT Keepalive
options. The downgraded version no longer supports those and therefore barfs if
you have them in your VPN configuration

Version-Release number of selected component (if applicable):

NetworkManager-vpnc-0.6.4-1.fc6

How reproducible: Always


Steps to Reproduce:
1. Set Rekeying or NAT Keepalive in VPN config
2. Start VPN connection
  
Actual results:

Feb 16 18:55:01 l3f1199 NetworkManager: <information>   VPN Activation (XXX)
Stage 3 of 4 (Connect) request sent, waiting for reply...
Feb 16 18:55:01 l3f1199 NetworkManager: <information>   VPN service
'org.freedesktop.NetworkManager.vpnc' signaled state change 6 -> 3.
Feb 16 18:55:01 l3f1199 NetworkManager: <WARNING>       
nm_vpn_service_process_signal (): VPN failed for service
'org.freedesktop.NetworkManager.vpnc', signal 'VPNConfigBad', with message 'The
VPN login failed because the VPN configuration options were invalid.'.

Expected results: The options should be supported


Additional info:

Comment 1 Denis Leroy 2007-02-18 08:25:15 UTC
Fixed.



Note You need to log in before you can comment on or make changes to this bug.