Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229025 - HTS: "hts submit" gave errors, and didn't created results*.rpm
Summary: HTS: "hts submit" gave errors, and didn't created results*.rpm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact:
URL:
Whiteboard:
: 227665 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-16 16:30 UTC by Danny Trinh
Modified: 2008-07-16 22:00 UTC (History)
6 users (show)

Fixed In Version: R32
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-18 15:33:15 UTC


Attachments (Terms of Use)
output.log of cdrom test (deleted)
2007-02-16 16:30 UTC, Danny Trinh
no flags Details
results.xml of cdrom test (deleted)
2007-02-16 16:33 UTC, Danny Trinh
no flags Details

Description Danny Trinh 2007-02-16 16:30:45 UTC
Description of problem:
After running cdrom test (hts print showed the test passed), "hts submit" failed
to create results*.rpm file and print errors on display (see below).
[root@localhost temp]# hts submit
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
loaded results /var/hts/results.xml
Traceback (most recent call last):
  File "/usr/bin/hts", line 113, in ?
    success = hts.do(args)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 73, in do
    return self.doSubmit()      
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 370, in doSubmit
    if report.WriteResultsRPM(self.LogDirectory):
  File "/usr/lib/python2.4/site-packages/hts/report.py", line 192, in
WriteResultsRPM
    self.WriteLogForRPM(testsByName[testName], runNumber, [byTestDirectory,
byRunDirectory])
  File "/usr/lib/python2.4/site-packages/hts/report.py", line 235, in WriteLogForRPM
    log.write(outputLog)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xb1' in position
24549: ordinal not in range(128)
[root@localhost temp]# 


Version-Release number of selected component (if applicable):
hts-5.0-25

How reproducible:
every time

Steps to Reproduce:
1.Install RHEL5-RC1-i386 to the system with a CD-RW/DVD+RW drive (in this case,
I used TEAC DVD+RW DV-W58E)
2.Install hts-5.0-25 + dependencies rpms
3.run: "hts plan", "hts certify -t cdrom", "hts print", "hts submit"
  
Actual results:
Can't make result*.rpm to submit to hardware.redhat.com

Expected results:
Must be able to create results*.rpm when run "hts submit".

Additional info:
Below is the output of "hts print" after running certify test.
[root@localhost ~]# hts print
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
loaded results /var/hts/results.xml

Red Hat Hardware Certification test
--------------------------------------------
Test Suite:    5.0    Release: 25
Plan Created:  2007-02-15 12:16:42
Test Server:   
--------------------------------------------

Run: 1 on 2007-02-15 12:17:17
--------------------------------------------
Tests: 11 planned,  2 run, 2 passed, 0 failed
--------------------------------------------


Test Run 1
----------------------------------------------------------------
cdrom      TEAC DVD+RW DV-W58E                  - PASS
cdrom      Optiarc DVD+/-RW ND-3570A            - 
floppy     PC Floppy Drive                      - 
usb        Computer                             - 
network    Networking Interface                 - 
storage    ST3750640AS                          - 
storage    WDC WD2500JS-75N                     - 
video      ES1000                               - 
info       Computer                             - PASS
memory     Computer                             - 
core       Computer                             - 

Combined Results for 1 Runs:
--------------------------------------------
   11 tests planned
   2 tests run
   0 tests always failed
   2 tests always passed
[root@localhost ~]#

Comment 1 Danny Trinh 2007-02-16 16:30:50 UTC
Created attachment 148206 [details]
output.log of cdrom test

Comment 2 Danny Trinh 2007-02-16 16:33:35 UTC
Created attachment 148207 [details]
results.xml of cdrom test

Comment 3 Danny Trinh 2007-02-22 14:42:54 UTC
Can RH look into this bug? We can't pack-up the results to *.rpm to submit to
hardware.redhat.com.

Comment 4 Danny Trinh 2007-03-06 15:18:36 UTC
Ping!
Dell had several dvd+/-rw drives need to test, but hts failed to do the jobs.
What will Dell do to get those drive certified?


Comment 5 YangKun 2007-03-07 06:34:34 UTC
Please do the following check and see whether this issue still exist:
  1) This error may caused by data inconsistency after user manually
killed(Ctrl-C) running tests. Please remove all *.xml files(config.xml, plan.xml
and results.xml) under /var/hts/ directory , then re-run the tests;

  2) Currently, only en_US locale is supported. If you've set the locale to
other languages, plaese change it to en_US, and remove all *.xml files under
/var/hts/ directory , then re-run the tests.

Please keep using hts-5.0-25 to test. 

Thanks

Comment 6 YangKun 2007-03-07 09:31:04 UTC
*** Bug 227665 has been marked as a duplicate of this bug. ***

Comment 7 Greg Nichols 2007-03-07 15:53:01 UTC
I can rule out issue 1) the results.xml is ok.

Comment 8 Danny Trinh 2007-03-07 16:04:52 UTC
issue 2: My kickstart.cfg contained the following:
lang en_US
keyboard us

Therefore, it should be en_US locale.
I'm curious, where do you check locale setting? /etc/sysconfig/i18n?

Thanks,

Comment 9 Danny Trinh 2007-03-09 22:12:27 UTC
Same errors on hts-5.0-30

Comment 10 Larry Troan 2007-03-13 02:11:23 UTC
Per Danny Trinh at Dell....
Bug#229025 is stopper. Precision 690n, Precision 490n,
Precision 390n will not be done if bug#229025 is not solved.

Comment 11 Yu Shao 2007-03-13 02:22:57 UTC
Hi Danny,

Please use hts r31 which has just been released, in r31 a patch is also included
to enable you patch r26 result rpm to avoid retesting.

Let's know if you still have problem.

Cheers,
Shao

Comment 13 YangKun 2007-03-13 02:55:52 UTC
Hi Danny,

Please try to remove all ".pyc" and ".pyo" files under the directory
"/usr/lib/python2.4/site-packages/hts/" first , then re-run "hts submit", see if
the result rpm is generated. If not, please manually package the results like
following:

  1) tar jcvf var-log-hts.tar.bz2 /var/log/hts/
  2) tar jcvf var-hts.tar.bz2 /var/hts/

then, please attach these two tar files(var-log-hts.tar.bz2 and var-hts.tar.bz2)
as attachments to hardware.redhat.com , we can manually review them.

Thanks

Comment 14 Yu Shao 2007-03-13 03:17:51 UTC
Danny, please let us know the cerd id if you could only attach tarball, so
hwcert could leverage from there.

Thanks
Shao

Comment 16 Greg Nichols 2007-03-13 16:21:16 UTC
Fixed unicode error on hts submit for R32.  Leaving in NEEDINFO to facilitate
manual review of existing results.

Comment 17 Danny Trinh 2007-03-13 22:10:31 UTC
Please see the bug#232131 for more info. about the cert ID.
There are more to come.

Comment 18 YangKun 2007-03-14 02:31:31 UTC
bug#232131 is processed , and the unicode error is fixed in R32 . closing this
bug now.

Comment 19 Greg Nichols 2007-03-14 02:54:17 UTC
Re-opened, put in MODIFIED, pending verification once R32 is made available.

Comment 20 Danny Trinh 2007-03-14 14:46:20 UTC
Is there a way that I can get R32 to run for verification? Thanks, Danny


Note You need to log in before you can comment on or make changes to this bug.