Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229020 - cannot read, but can write to motorola a1200 in storage mode
Summary: cannot read, but can write to motorola a1200 in storage mode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-16 15:54 UTC by ritz
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.6.20-1.3045.fc7PAE
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 08:10:03 UTC


Attachments (Terms of Use)

Description ritz 2007-02-16 15:54:38 UTC
Description of problem:
I cannot use cp to copy files from my phone motorola a1200 in storage mode. This
worked fine FC5.

Version-Release number of selected component (if applicable):
Linux localhost 2.6.20-1.2930.fc7 #1 SMP Wed Feb 14 17:25:18 EST 2007 i686 i686
i386 GNU/Linux

How reproducible:
always

Steps to Reproduce:
1. plug in the phone in storage mode
2. mount partition 
3. read using cp
  
Actual results:
cannot copy files from device, but can write.

Expected results:
can read and write.

Additional info:
Initializing USB Mass Storage driver...
scsi2 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 7
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 2:0:0:0: Direct-Access     Motorola Phone                 PQ: 0 ANSI: 4
SCSI device sdb: 990976 512-byte hdwr sectors (507 MB)
sdb: Write Protect is off
sdb: Mode Sense: 10 00 00 00
sdb: assuming drive cache: write through
SCSI device sdb: 990976 512-byte hdwr sectors (507 MB)
sdb: Write Protect is off
sdb: Mode Sense: 10 00 00 00
sdb: assuming drive cache: write through
 sdb: sdb1
sd 2:0:0:0: Attached scsi disk sdb
sd 2:0:0:0: Attached scsi generic sg1 type 0
sd 2:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 2:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 2:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 2:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 2:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 2:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 2:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 2:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
usb 5-8.2.4: USB disconnect, address 7
usb 5-8.2.4: new full speed USB device using ehci_hcd and address 8
usb 5-8.2.4: configuration #1 chosen from 1 choice
scsi3 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 8
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 3:0:0:0: Direct-Access     Motorola Phone                 PQ: 0 ANSI: 4
SCSI device sdb: 990976 512-byte hdwr sectors (507 MB)
sdb: Write Protect is off
sdb: Mode Sense: 10 00 00 00
sdb: assuming drive cache: write through
SCSI device sdb: 990976 512-byte hdwr sectors (507 MB)
sdb: Write Protect is off
sdb: Mode Sense: 10 00 00 00
sdb: assuming drive cache: write through
 sdb: sdb1
sd 3:0:0:0: Attached scsi disk sdb
sd 3:0:0:0: Attached scsi generic sg1 type 0
sd 3:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 3:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 3:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 3:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 3:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 3:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 3:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
sd 3:0:0:0: SCSI error: return code = 0x08000002
sdb: Current: sense key: Medium Error
    ASC=0x0 ASCQ=0x5a
end_request: I/O error, dev sdb, sector 990968
Buffer I/O error on device sdb, logical block 123871
usb 5-8.2.4: reset full speed USB device using ehci_hcd and address 8

Comment 1 ritz 2007-02-16 15:55:45 UTC
no error or issue seen on FC5 kernel.

Comment 2 Pete Zaitcev 2007-02-16 18:05:26 UTC
What's the reported size on FC-5? I'd like to see the content of
/sys/block/sda/size on FC-5 (should be sda because FC-5 had no libata)
and /sys/block/sdb/size on FC-6.

The strange block size (4KB!) is really suspicious. I suspect that FAT
forgets to set the right sector size on the device. I remember dimly
that the necessary call had to be added to it, maybe it was lost.


Comment 3 ritz 2007-02-16 19:33:37 UTC
From RHEL4,FC5, and rawhide.
$ cat /sys/block/sda/size 
990976 




Comment 4 ritz 2007-02-16 20:06:48 UTC
will check up with my home box, and confirm.

Comment 5 ritz 2007-02-20 14:22:24 UTC
home box is gone for a toss. cannot verify.
using a card reader as a workaround.

i can write to phone, but i cannot copy file from phone :(


Comment 6 ritz 2007-04-09 08:10:03 UTC
works fine with kernel 2.6.20-1.3045.fc7PAE

no more error messages .


Note You need to log in before you can comment on or make changes to this bug.