Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229016 - Virtual console unavailable after DomU migration
Summary: Virtual console unavailable after DomU migration
Keywords:
Status: CLOSED DUPLICATE of bug 211921
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Berrange
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-16 15:21 UTC by Jim Klein
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-22 19:40:34 UTC


Attachments (Terms of Use)
dest debug log (deleted)
2007-02-21 17:34 UTC, Jim Klein
no flags Details
src debug log (deleted)
2007-02-21 17:34 UTC, Jim Klein
no flags Details
dst log (deleted)
2007-02-21 17:35 UTC, Jim Klein
no flags Details
src log (deleted)
2007-02-21 17:36 UTC, Jim Klein
no flags Details

Description Jim Klein 2007-02-16 15:21:18 UTC
Virtual console no longer works after migrating a domain from one box to
another. DomU is still fully functional in every other respect and accessible
via xm, ssh, etc.

Comment 1 Daniel Berrange 2007-02-21 16:35:41 UTC
Not enough info to diagnose the problem - please provide at the very least

 - RPM versions for  'xen', 'libvirt' and 'virt-manager' in your Dom0
 - The kernel version used in the guest DomU
 - The '/var/log/xend.log' & xend-debug.log from both source & destination
machine involved in the migration
 - The /etc/xen/<name>  config file for the guest VM being migrated

Are you referring to the graphical console, or the text (serial) console of the VM ?


Comment 2 Jim Klein 2007-02-21 17:34:05 UTC
Created attachment 148506 [details]
dest debug log

Comment 3 Jim Klein 2007-02-21 17:34:47 UTC
Created attachment 148507 [details]
src debug log

Comment 4 Jim Klein 2007-02-21 17:35:21 UTC
Created attachment 148508 [details]
dst log

Comment 5 Jim Klein 2007-02-21 17:36:00 UTC
Created attachment 148509 [details]
src log

Comment 6 Jim Klein 2007-02-21 17:38:13 UTC
libvirt-0.1.7-2, virt-manager-0.2.6-3, xen-3.0.3-0.1.rc3, kernels
2.6.18-1.2747,2.6.18-1.2798, 2.6.18-1.2869


Logs attached. These are fresh logs after a RHEL5 migrate from source to dest
and back again. Problem also occurs with Fedora domUs running any of the above
kernels.

Graphical console.

Comment 7 Daniel Berrange 2007-02-22 19:40:34 UTC
Ok, these package versions show you're using a version of the kernel/xen with
the old style paravirt framebuffer protocol. This original implemnetation did
not support migration. Prior to RHEL-5  GA we merged a new style framebuffer
implementation which does support migration.

The fix is in the following versions (or later):

kernel-xen-2.6.18-7.el5
xen-3.0.3-17.el5

They will be included in the RHEL-5  GA release.


*** This bug has been marked as a duplicate of 211921 ***


Note You need to log in before you can comment on or make changes to this bug.