Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229006 - ConsoleKit spews all over serial console
Summary: ConsoleKit spews all over serial console
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ConsoleKit
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: jmccann
QA Contact:
URL:
Whiteboard:
: 230937 231010 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-16 14:21 UTC by Jarod Wilson
Modified: 2015-01-14 23:20 UTC (History)
6 users (show)

Fixed In Version: 0.2.0-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-25 12:07:44 UTC


Attachments (Terms of Use)
daemonize properly (deleted)
2007-03-19 19:53 UTC, David Zeuthen
no flags Details | Diff
grep console- of 2008-04-24 week's notes (deleted)
2008-04-23 13:31 UTC, David Timms
no flags Details

Description Jarod Wilson 2007-02-16 14:21:03 UTC
Description of problem:
Current rawhide system w/a serial console set up encounters large amounts of
spew at startup from the console-kit-daemon. (currently unable to find a
ConsoleKit bugzilla component, this seemed to be as close as I could get).

Console spew:

Starting console-kit daemon: 
** (console-kit-daemon:2159): CRITICAL **: Unable to open console: Invalid argument
ioctl VT_GETSTATE: Bad file descriptor
[  OK  ]

** (console-kit-daemon:2159): WARNING **: Error waiting for native console 56
activation: Bad file descriptor

** (console-kit-daemon:2159): WARNING **: Error waiting for native console 58
activation: Bad file descriptor

** (console-kit-daemon:2159): WARNING **: Error waiting for native console 59
activation: Bad file descriptor

[...repeats around 60+ times for various native console values between 1 and 62...]

Comment 1 Jarod Wilson 2007-02-16 16:12:49 UTC
Okay, ConsoleKit component exists now...

Comment 2 David Zeuthen 2007-02-16 17:17:09 UTC
Jon, do you have any idea about this? Otherwise I'll try to look into it next
week. Thanks.

Comment 3 David Zeuthen 2007-02-16 18:57:43 UTC
Jarod, as far as I understand the problem is only CK spewing errors; it doesn't
sabotage any of your consoles right? Thanks.

Comment 4 Jarod Wilson 2007-02-16 19:34:54 UTC
Correct, I can still login on vt1, serial console and via gdm without a problem.

Comment 5 Jarod Wilson 2007-02-16 19:50:28 UTC
I should probably add that a graphical login also results in this getting dumped
on the serial console:

audit(1171654461.698:5): user pid=1963 uid=81 auid=4294967295
subj=system_u:system_r:system_dbusd_t:s0 msg='avc:  denied  { send_msg } for
msgtype=method_call interface=org.freedesktop.ConsoleKit.Manager
member=OpenSessionWithParameters dest=org.freedesktop.ConsoleKit spid=2544
tpid=2222 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:system_r:initrc_t:s0 tclass=dbus
: exe="/bin/dbus-daemon" (sauid=81, hostname=?, addr=?, terminal=?)'

Comment 6 jmccann 2007-02-19 21:02:17 UTC
CK is using the getfd.c (copied from the kbd package) to get a fd that can be
used with console ioctls.  Apparently, getfd() is not finding one.  I'll try to
reduce the spew when this is the case.

Comment 8 Jarod Wilson 2007-02-28 16:02:40 UTC
I munged said patch to apply to the ConsoleKit we've got in rawhide right now,
and the results certainly look much better. All I see on the serial console now is:

Starting console-kit daemon: 
** (console-kit-daemon:2165): WARNING **: Unable to open console: Invalid argument
[  OK  ]

Comment 9 David Zeuthen 2007-02-28 17:06:49 UTC
Probably ConsoleKit needs to close stdin, stdout and stderr when daemonizing...


Comment 10 David Zeuthen 2007-03-19 19:26:59 UTC
*** Bug 231010 has been marked as a duplicate of this bug. ***

Comment 11 David Zeuthen 2007-03-19 19:27:13 UTC
*** Bug 230937 has been marked as a duplicate of this bug. ***

Comment 12 David Zeuthen 2007-03-19 19:53:41 UTC
Created attachment 150424 [details]
daemonize properly

Jon, how about this patch? This is what I just put in Rawhide for the 0.2.0
release.

Comment 13 David Zeuthen 2007-03-19 19:55:29 UTC
Anyway, this patch is in our 0.2.0 packages and should fix any spews from the
ConsoleKit daemon. Please reopen if this doesn't work. Thanks.

Comment 14 jmccann 2007-03-19 20:06:56 UTC
Yeah it is fine.  But this bug shows why I didn't close stderr.  It helped us
find a bug :)

Comment 15 David Timms 2008-04-23 13:31:40 UTC
Created attachment 303491 [details]
grep console- of 2008-04-24 week's notes

I don't know if ConsoleKit has been quiet since 2007-03, but at the moment on
rawhide,it is giving var/log/messages re environ, glib assertions, passed as
NULL warnings.

v ConsoleKit-0.2.10-3.fc9.i386

Comment 16 David Timms 2008-04-23 13:33:17 UTC
Getting very similar messages to bug 230937, one year after this fix. Reopening.

Comment 17 jmccann 2008-04-23 16:42:14 UTC
That looks like an entirely different issue to me.  Can you please open a new
bug.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.