Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229 - ';' missing in /etc/rc.d/init.d/autofs
Summary: ';' missing in /etc/rc.d/init.d/autofs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autofs
Version: 5.2
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-30 09:55 UTC by Marc MERLIN
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-16 21:41:41 UTC


Attachments (Terms of Use)

Description Marc MERLIN 1998-11-30 09:55:10 UTC
There are two lines like this one:
TMP1=`mktemp /tmp/autofs.XXXXXX` || { echo "could not make
temp file" >&2; exit 1; }

The default script is missing the last ';'. It works anyway
with bash 1.14 but fails with 2.x because it enforces the
grammar.
This is not a bug for RH 5.2, but since you have bash 2.02
in rawhide, I suppose you're going to switch to the newer
bash and be bitten by this eventually.

There is also a problem with ifup-alias where
allow_null_glob_expansion has to be replaced with
shopt -(s|u) nullglob.
I don't know if you wish to receive reports like this one in
the future. Please advise.


BTW, the script (and many other for that matter) is also
missing
the ';;' just before esac at the end of the file:

  *)
        echo "Usage: /etc/rc.d/init.d/autofs
{start|stop|restart|reload|status}"
        exit 1
        ;;
esac

Here again, bash will be lenient, but according to the man
page, this is a syntax error. Vim with color syntaxing also
shows this as an error. It works for now, but it might be a
good idea to fix those.

Comment 1 Bill Nottingham 1998-11-30 15:59:59 UTC
should be fixed already in the Raw Hide version...


Note You need to log in before you can comment on or make changes to this bug.