Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228994 - yum-updatesd stops reporting updates
Summary: yum-updatesd stops reporting updates
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
: 231593 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-16 12:49 UTC by David Juran
Modified: 2014-01-21 22:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-03 19:42:38 UTC


Attachments (Terms of Use)

Description David Juran 2007-02-16 12:49:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20070209 Fedora/1.5.0.9-3.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
I've noticed that after running for ~24 hours, yum-updatesd stops reporting new updates. Running lsof shows that it has the following two TCP sockets (and only those two) open, both which are inte the CLOSE_WAIT state:

yum-updat  3877      root    8u     IPv4      17819                 TCP a88-115-202-179.elisa-laajakaista.fi:35443->fpserv.fedoraproject.org:http (CLOSE_WAIT)
yum-updat  3877      root    9u     IPv4      17754                 TCP a88-115-202-179.elisa-laajakaista.fi:59865->ie.freshrpms.net:http (CLOSE_WAIT)

Furthermore, strace shows that it's repeatingly doing a poll on two file descriptors, one of which is a UNIX domain socket which no other process than the yum-updatesdaemon has open and the other one is a pipe of which yum-updatesd has both ends open but no-one else is using it...

Attaching with gdb to yum-updatesd yields the following backtrace: (Is there a way of attaching to a python program and actually debugging the python code?)
#0  0x00c97402 in __kernel_vsyscall ()
#1  0x4e41269b in poll () from /lib/libc.so.6
#2  0x41ea8453 in g_main_context_iterate (context=0x9b149f0, block=1, dispatch=1, self=0x9a66508) at gmain.c:2979
#3  0x41ea87c9 in IA__g_main_loop_run (loop=0x9ac40f8) at gmain.c:2881
#4  0x00d0731c in _wrap_g_main_loop_run (self=0xb7fac580) at pygmainloop.c:257
#5  0x4fa57f28 in PyEval_EvalFrame (f=0x96b6944) at Python/ceval.c:3552
#6  0x4fa582dd in PyEval_EvalFrame (f=0x96b648c) at Python/ceval.c:3651
#7  0x4fa591b5 in PyEval_EvalCodeEx (co=0xb7f369a0, globals=0xb7f88824, locals=0xb7f88824, args=0x0, argcount=0, kws=0x0, kwcount=0, defs=0x0, 
    defcount=0, closure=0x0) at Python/ceval.c:2741
#8  0x4fa59293 in PyEval_EvalCode (co=0xb7f369a0, globals=0xb7f88824, locals=0xb7f88824) at Python/ceval.c:484
#9  0x4fa76078 in run_node (n=<value optimized out>, filename=<value optimized out>, globals=0xb7f88824, locals=0xb7f88824, flags=0xbfe19334)
    at Python/pythonrun.c:1285
#10 0x4fa777b8 in PyRun_SimpleFileExFlags (fp=0x9681008, filename=0xbfe19ef3 "/usr/sbin/yum-updatesd", closeit=1, flags=0xbfe19334)
    at Python/pythonrun.c:869
#11 0x4fa77e9a in PyRun_AnyFileExFlags (fp=0x9681008, filename=0xbfe19ef3 "/usr/sbin/yum-updatesd", closeit=1, flags=0xbfe19334)
    at Python/pythonrun.c:673
#12 0x4fa7e825 in Py_Main (argc=1, argv=0xbfe19404) at Modules/main.c:493
#13 0x08048582 in main (argc=Cannot access memory at address 0x2
) at Modules/python.c:23


Oh, and ofcourse running 'yum' from the command-line reports that there are updates available.




Version-Release number of selected component (if applicable):
yum-updatesd-3.0.3-1.fc6

How reproducible:
Always


Steps to Reproduce:
1. leave your machine for ~24 hours
2. note that yum-updatesd does not report updates although they are available


Actual Results:


Expected Results:


Additional info:

Comment 1 David Juran 2007-02-16 13:01:46 UTC
Also, if restarting the yum-updatesd, it will then pick up the new updates.

Comment 2 k3dzngrp8w2xtc9 2007-03-13 19:32:15 UTC
"For me too."

Yum-updatesd is running and periodically wakes up, but the icon in the GNOME
notification area only shows 1 update available. However when running pup, it
detects 6.

When the available updates are not of a security nature, and the user chooses
not to apply them, further (possibly security) bugs should still be reported!

Comment 3 Jeremy Katz 2007-04-09 20:54:56 UTC
*** Bug 231593 has been marked as a duplicate of this bug. ***

Comment 4 Patrick Steiner 2007-06-28 04:38:16 UTC
same problem with F7

Comment 5 David Juran 2007-07-10 06:30:48 UTC
Indeed the problem still exists on Fedora 7, although in a slightly different
incarnation. On FC-6, as stated in comment 1, restarting yum-updatesd made it
pick up the new updates. In F-7 (yum-updatesd-3.2.1-1.fc7), not even restarting
yum-updatesd helps. Running "dbus-monitor --system" produces the following lines
when restarting yum-updatesd, but that's also all that does happen:

signal sender=org.freedesktop.DBus -> dest=(null destination)
path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string ":1.51"
   string ""
   string ":1.51"
signal sender=org.freedesktop.DBus -> dest=(null destination)
path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string "edu.duke.linux.yum"
   string ""
   string ":1.51"

Running "yum upgrade" from the command line shows lots of updates are available.

Comment 6 Seth Vidal 2007-08-03 19:42:38 UTC
please try yum-updatesd from rawhide. Reopen this bug if it persists


Note You need to log in before you can comment on or make changes to this bug.