Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228973 - Kernel 2.6.19 hardlock on boot with adaptec i2o driver. ( SmartRAID V IDE controller )
Summary: Kernel 2.6.19 hardlock on boot with adaptec i2o driver. ( SmartRAID V IDE con...
Keywords:
Status: CLOSED DUPLICATE of bug 228946
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-16 10:22 UTC by Joni Bäcklund
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-16 10:29:08 UTC


Attachments (Terms of Use)

Description Joni Bäcklund 2007-02-16 10:22:42 UTC
Description of problem:

With all 2.6.19 kernels for FC6 the system wont boot. Just tested
2.6.19-1.2911.fc6 and the same result was seen. The system panics while booting
. I can not produce logs as there is no serial port on the system. But when
systems tries to resume from /dev/i2o/hda1 ( swap  partition ) kernel reports
I/O error on device i2o/hda. 

The system works ok with other kernels aka. 2.6.18 series and it is running
latest 2.6.18 series ( 2.6.18-1.2869.fc6 ) just now.

It seems to me that the i2o driver is broken on 2.6.19 ! 

dmesg from the working 2.6.18 is as follows:

I2O subsystem v1.325
i2o: max drivers = 8
i2o: Checking for PCI I2O controllers...
ACPI: PCI Interrupt 0000:00:0b.0[A] -> GSI 19 (level, low) -> IRQ 169
iop0: controller found (0000:00:0b.0)
iop0: limit sectors per request to 128
iop0: PCI I2O controller at E4000000 size=1048576
iop0: Installed at IRQ 169
i2o: iop0: Activating I2O controller...
i2o: iop0: This may take a few minutes if there are many devices
input: PS/2 Logitech Mouse as /class/input/input1
iop0: HRT has 1 entries of 16 bytes each.
Adapter 00000012: TID 0000:[HPC*]:PCI 1: Bus 1 Device 22 Function 0
i2o: iop0: Controller added
I2O Block Device OSM v1.325
block-osm: registered device at major 80
 i2o/hda: i2o/hda1 i2o/hda2 i2o/hda3 i2o/hda4
block-osm: device added (TID: 207): i2o/hda

I did check that the initrd has the right modules but the system does not
boot as it can not read i2o/hda with 2.6.19 kernel.


Version-Release number of selected component (if applicable):
all 2.6.19 update kernels for fc6 that I tested. 

How reproducible:
boot the 2.6.19 kernel

Steps to Reproduce:
1.reboot
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Joni Bäcklund 2007-02-16 10:29:08 UTC

*** This bug has been marked as a duplicate of 228946 ***


Note You need to log in before you can comment on or make changes to this bug.