Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228956 - F7 test1 stack traceback when mounting an xfs filesystem
Summary: F7 test1 stack traceback when mounting an xfs filesystem
Keywords:
Status: CLOSED DUPLICATE of bug 229520
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-16 05:32 UTC by David Keaton
Modified: 2015-03-05 01:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-20 03:11:17 UTC


Attachments (Terms of Use)
Stack traceback extracted from /var/log/messages. (deleted)
2007-02-16 05:32 UTC, David Keaton
no flags Details

Description David Keaton 2007-02-16 05:32:37 UTC
Description of problem:
F7 test1 reports possible recursive locking and gives a stack traceback when
trying to mount an xfs filesystem.

Version-Release number of selected component (if applicable):
2.6.20-1.2930.fc7 i686 32-bit

How reproducible:
Mount an xfs filesystem.

Steps to Reproduce:
1.  Create an xfs filesystem or find an existing one.
2.  Mount it.
3.  Observe /var/log/messages.
  
Actual results:
Complaint about possible recursive locking being detected, along with a stack
traceback.  Some filesystem operations appear to work afterwards, but I haven't
trusted it enough to give it an extensive workout.  (My xfs filesystems have
live data that I don't want to lose.)

Expected results:
Normal mount and everything works with no complaints.

Additional info:
Stack traceback attached.

Comment 1 David Keaton 2007-02-16 05:32:37 UTC
Created attachment 148171 [details]
Stack traceback extracted from /var/log/messages.

Comment 2 David Keaton 2007-04-06 19:30:48 UTC
This is confirmed still a problem in F7 test3 updated to 2.6.20-1.3045.fc7.

It appears that the traceback does not occur until the first access to the
filesystem.  I can mount an xfs filesystem, and if it is not accessed, there is
no traceback.


Comment 3 Eric Sandeen 2007-04-20 03:11:17 UTC
This is really just a lockdep annotation problem, shouldn't affect functionality.

*** This bug has been marked as a duplicate of 229520 ***


Note You need to log in before you can comment on or make changes to this bug.