Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228771 (yum-pre-error) - yum error handling looks quite confused
Summary: yum error handling looks quite confused
Keywords:
Status: CLOSED DUPLICATE of bug 216221
Alias: yum-pre-error
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 21:22 UTC by Michal Jaegermann
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-09 20:40:06 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2007-02-14 21:22:03 UTC
Description of problem:

Preinstall script from control-center-2.17.91-1.fc7 ends with
a status 1.  This has the following effects in yum:

Running Transaction
error: %pre(control-center-2.17.91-1.fc7.x86_64) scriptlet failed,
exit status 1
error:   install: %pre scriptlet failed (2), skipping control-center-2.17.91-1.fc7

Updated: control-center.x86_64 1:2.17.91-1.fc7
Complete!

The above would be fine if not the last two lines above and
a /var/log/yum entry which says:

Feb 14 14:13:10 Updated: control-center.x86_64 1:2.17.91-1.fc7

while 'rpm -q control-center' knows only about
control-center-2.17.90-6.fc7

Version-Release number of selected component (if applicable):
yum-3.1.1-2.fc7

How reproducible:
on every try

Comment 1 Jeremy Katz 2007-02-21 22:06:09 UTC
The problem here is that rpmlib doesn't actually give any indication to callers
that there was an error :/

Comment 2 Seth Vidal 2007-08-03 19:39:57 UTC
reassigning to rpm

Comment 3 Panu Matilainen 2007-08-09 20:40:06 UTC
Different scriptlet failing but the core issue is the same...

*** This bug has been marked as a duplicate of 216221 ***


Note You need to log in before you can comment on or make changes to this bug.