Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228753 - Yum Metadata Checksum Problem
Summary: Yum Metadata Checksum Problem
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-metadata-parser
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 20:10 UTC by Glenn Rottingen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-19 22:08:29 UTC


Attachments (Terms of Use)

Description Glenn Rottingen 2007-02-14 20:10:42 UTC
Description of problem:[root@localhost ~]# yum clean metadata
Loading "installonlyn" plugin
18 metadata files removed
[root@localhost ~]# yum -y update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
dries                     100% |=========================|  951 B    00:00     
core                      100% |=========================| 1.1 kB    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
freshrpms                 100% |=========================|  951 B    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 785 kB    00:01     
primary.xml.gz            100% |=========================| 1.0 MB    00:01     
primary.xml.gz            100% |=========================| 529 kB    00:19     
primary.xml.gz            100% |=========================|  63 kB    00:01     
primary.xml.gz            100% |=========================| 1.8 MB    00:03     
ftp://fedora.mirrors.tds.net/pub/fedora-core-extras/6/x86_64/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 1.8 MB    00:05     
http://redhat.download.fedoraproject.org/pub/fedora/linux/extras/6/x86_64/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 1.8 MB    00:33     
ftp://mirror.newnanutilities.org/pub/fedora/linux/extras/6/x86_64/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 1.8 MB    00:03     
http://download.fedora.redhat.com/pub/fedora/linux/extras/6/x86_64/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 1.8 MB    00:05     
http://www.gtlib.cc.gatech.edu/pub/fedora.redhat/linux/extras/6/x86_64/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 1.8 MB    00:07     
ftp://fedora.bu.edu/fedora/extras/6/x86_64/repodata/primary.xml.gz: [Errno -1]
Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 1.8 MB    00:03     
http://mirrors.kernel.org/fedora/extras/6/x86_64/repodata/primary.xml.gz: [Errno
-1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 1.8 MB    00:40     
extras    : ################################################## 5817/5817
No Packages marked for Update/Obsoletion
[root@localhost ~]# 



Version-Release number of selected component (if applicable):


How reproducible:  Happend on two different systems.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Fred New 2007-03-17 15:16:35 UTC
I assume this is because some repositories aren't current. I'm experiencing the
same problem with Fedora 7 test 2. This message often repeats more than 10
times, meaning that I've waited for 15-25 megabytes of wasted downloads.

As an enhancement, would it be possible to just download the checksum of the
file before downloading megabytes of data? That is, could we store a
primary.xml.gz.sha1 file on the repository so that yum could intelligently
decide not to download primary.xml.gz?

Comment 2 Jeremy Katz 2007-03-19 22:08:29 UTC
The right answer here is to improve the mirror infrastructure so that you don't
get pointed at out of date mirrors at all.  mdomsch is working on this with the
MirrorManager bits and hopefully that will be in use RSN.  Also, there's a
problem with the backend storage that mirrors sync from currently which is
making syncs a bit slower and exacerbating this.


Note You need to log in before you can comment on or make changes to this bug.