Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228734 - registering system with PAM/LDAP user
Summary: registering system with PAM/LDAP user
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 420
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 18:34 UTC by David Huff
Modified: 2007-07-31 16:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-15 19:44:42 UTC


Attachments (Terms of Use)

Description David Huff 2007-02-14 18:34:21 UTC
Description of problem:
When trying to register a system to satellite with a user that uses PAM LDAP for
authentication rhn_reg and up2date --register fails.  

Version-Release number of selected component (if applicable):
I have experienced this behavior on both Sat 4.20 and 4.15.

How reproducible:
yes

Steps to Reproduce:
1.Configure the sat to use PAM LDAP AUTH: 
 -add pam_auth_service = rhn-satellite to /etc/rhn/rhn.conf
 -create a /etc/pam.d/rhn-satellite file:
  	#%PAM-1.0
	auth required /lib/security/pam_env.so	
	auth sufficient /lib/security/pam_ldap.so no_user_check
	auth required /lib/security/pam_deny.so
	account required /lib/security/pam_ldap.so no_user_check
 -edit /etc/ldap.cong to talk to your ldap server

2. Create a user on the satellite and check use PAM auth

3. Run rhn_register form a client machine and use the ldap user you just created
  
Actual results:
rhn_register crashes machien does not register


Expected results:
machine registers

Additional info:

Comment 1 Matthew Davis 2007-02-15 19:44:42 UTC
Can't reproduce, David & I believe its a problem with the installed satellite.


Note You need to log in before you can comment on or make changes to this bug.