Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228724 - "GNOME" Terminal" regression after "vte" update when using "csh"
Summary: "GNOME" Terminal" regression after "vte" update when using "csh"
Keywords:
Status: CLOSED DUPLICATE of bug 228720
Alias: None
Product: Fedora
Classification: Fedora
Component: vte
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 17:14 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-14 17:16:13 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2007-02-14 17:14:31 UTC
Description of problem:
After updating to "vte-0.15.3-1.fc7", "GNOME" Terminal" shows some
dysfunctional behaviour when "csh" is chosen: control characters
for "bold" mode stop working; so do several non-alphanumeric keys
such as "tab" and arrow keys. Consequently, file completion or
command history are not available anymore.

Version-Release number of selected component (if applicable):
vte-0.15.3-1.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade to "vte-0.15.3-1.fc7".
2. Open a new "GNOME" terminal window.
3. Try tab-completion, history function, etc.
  
Actual results:
Respective features do not work.

Expected results:
Respective features should continue to work.

Additional info:
Afer switching to "sh/bash", things work as expected. Likewise,
downgrading to "vte-0.15.2-1.fc7" allows to restore full
functionality. I have made sure that the issue described above
is not due to my ".cshrc" file by moving it away from my home
directory.

Comment 1 Behdad Esfahbod 2007-02-14 17:16:13 UTC

*** This bug has been marked as a duplicate of 228720 ***


Note You need to log in before you can comment on or make changes to this bug.