Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228720 - "GNOME" Terminal" regression after "vte" update when using "csh"
Summary: "GNOME" Terminal" regression after "vte" update when using "csh"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vte
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
: 228724 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 16:57 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-03 16:48:12 UTC


Attachments (Terms of Use)
Patch that resolves wrong TERM setting (deleted)
2007-02-16 09:25 UTC, Joachim Frieben
no flags Details | Diff
Improved patch that solves "TERM" variable issue (deleted)
2007-02-16 12:38 UTC, Joachim Frieben
no flags Details | Diff

Description Joachim Frieben 2007-02-14 16:57:51 UTC
Description of problem:
After updating to "vte-0.15.3-1.fc7", "GNOME" Terminal" shows some
dysfunctional behaviour when "csh" is chosen: control characters
for "bold" mode stop working; so do several non-alphanumeric keys
such as "tab" and arrow keys. Consequently, file completion or
command history are not available anymore.

Version-Release number of selected component (if applicable):
vte-0.15.3-1.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade to "vte-0.15.3-1.fc7".
2. Open a new "GNOME" terminal window.
3. Try tab-completion, history function, etc.
  
Actual results:
Respective features do not work.

Expected results:
Respective features should continue to work.

Additional info:
Afer switching to "sh/bash", things work as expected. Likewise,
downgrading to "vte-0.15.2-1.fc7" allows to restore full
functionality. I have made sure that the issue described above
is not due to my ".cshrc" file by moving it away from my home
directory.

Comment 1 Behdad Esfahbod 2007-02-14 17:15:03 UTC
Would you mind reporting this at bugzilla.gnome.org, so we can track it down?

Comment 2 Behdad Esfahbod 2007-02-14 17:16:15 UTC
*** Bug 228724 has been marked as a duplicate of this bug. ***

Comment 3 Joachim Frieben 2007-02-14 17:50:55 UTC
Reported upstream as http://bugzilla.gnome.org/show_bug.cgi?id=407945

Comment 4 Joachim Frieben 2007-02-16 09:25:19 UTC
Created attachment 148178 [details]
Patch that resolves wrong TERM setting

This patch corrects the erroneous setting of "TERM" to value "dumb".
After adding:

Patch0: replace-env-bz228720.patch
%patch0 -p0 -b .replace-env-bz228720

to the "spec" file, the package is rebuilt and works correctly regarding
the malfunction reported earlier.

Comment 5 Joachim Frieben 2007-02-16 09:31:30 UTC
A refined correction has again been suggested at
http://bugzilla.gnome.org/show_bug.cgi?id=407945#c16

Comment 6 Joachim Frieben 2007-02-16 12:38:08 UTC
Created attachment 148189 [details]
Improved patch that solves "TERM" variable issue

The 2nd patch works even better than the first one. I have had the
impression that the initial one did not work entirely correctly
although it solved my problem completely, because I have had some
trouble with "ctrl-c" after adding it.

Comment 7 Joachim Frieben 2007-03-03 16:47:54 UTC
Fixed in "vte-0.15.6-1.fc72.


Note You need to log in before you can comment on or make changes to this bug.