Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228713 - [RHEL4] [patch] cid-2 remove dead code in lib/ss/help.c
Summary: [RHEL4] [patch] cid-2 remove dead code in lib/ss/help.c
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: e2fsprogs
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Eric Sandeen
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks: 239341
TreeView+ depends on / blocked
 
Reported: 2007-02-14 16:30 UTC by Bryn M. Reeves
Modified: 2015-01-08 00:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-30 18:33:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
Remove invariant (code != 0) check in lib/ss/help.c (deleted)
2007-02-14 16:31 UTC, Bryn M. Reeves
no flags Details | Diff

Description Bryn M. Reeves 2007-02-14 16:30:59 UTC
Description of problem:
lib/ss/help.c contains the following lines in ss_help():

    request_name = ss_current_request(sci_idx, &code);
    if (code != 0) { 
        ss_perror(sci_idx, code, "");
        return;         /* no ss_abort_line, if invalid invocation */
    }

However, ss_current_request is defined in lib/ss/ss_internal.h as:

#define ss_current_request(sci_idx,code_ptr)    \
     (*code_ptr=0,ss_info(sci_idx)->current_request)

Since this clears &code, the conditional following the macro is not necessary.


Version-Release number of selected component (if applicable):
e2fsprogs-1.35-12.4.EL4

How reproducible:
Not really reproducible, since the ss_perror line is never executed anyway.

Comment 1 Bryn M. Reeves 2007-02-14 16:31:00 UTC
Created attachment 148063 [details]
Remove invariant (code != 0) check in lib/ss/help.c

Comment 5 RHEL Product and Program Management 2007-05-09 07:42:15 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 6 Eric Sandeen 2007-05-29 20:05:14 UTC
This patch was not accepted upstream

Comment 7 Eric Sandeen 2007-05-30 18:33:42 UTC
since this was NAK'd upstream, coupled with the fact that dead code removal
isn't really acceptable for rhel changes, setting this one to NOTABUG.

http://lists.openwall.net/linux-ext4/2007/03/18/4


Note You need to log in before you can comment on or make changes to this bug.