Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 228710 - setpagedevice without Begin/EndFeature pair in print output
Summary: setpagedevice without Begin/EndFeature pair in print output
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 16:26 UTC by Tim Waugh
Modified: 2018-04-11 13:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-15 22:47:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CUPS Bugs and Features 1542 None None None Never
Mozilla Foundation 334485 None None None Never

Description Tim Waugh 2007-02-14 16:26:24 UTC
Description of problem:
When printing a page from Firefox, the print output looks like this:

[...]
%%BeginProlog
/setpagedevice where
{ pop 2 dict
  dup /PageSize [ 595.25 841.9 ] put
  dup /Policies 1 dict
    dup /PageSize 3 put
  put
  setpagedevice
} if
[ /.notdef /.notdef /.notdef /.notdef /.notdef /.notdef
[...]

but I think it should look like this:

[...]
%%BeginProlog
%%BeginFeature: *PageSize A4
/setpagedevice where
{ pop 2 dict
  dup /PageSize [ 595.25 841.9 ] put
  dup /Policies 1 dict
    dup /PageSize 3 put
  put
  setpagedevice
} if
%%EndFeature: *PageSize
[ /.notdef /.notdef /.notdef /.notdef /.notdef /.notdef
[...]

See CUPS STR #1542 for the original complaint:
  http://www.cups.org/str.php?L1542

==>
Please note: Mozilla's output also contains a setpagedevice command without a
corresponding Begin/EndFeature pair, which might cause problems with some
printers...

Please file a bug upstream with them to add:

    %%BeginFeature: *PageSize sizename
    ... existing code
    %%EndFeature: *PageSize

"sizename" would be "Letter", "A4", etc.
<==

Version-Release number of selected component (if applicable):
firefox-1.5.0.9-3.fc6

How reproducible:
100%

Steps to Reproduce:
1. Print something (anything) to file, and examine the results

Comment 1 Matěj Cepl 2007-05-15 22:47:06 UTC
It is not exactly duplicate of this bug, but when this
https://bugzilla.mozilla.org/show_bug.cgi?id=334485 upstream bug is resolved,
this bug will become automatically obsolete, because there will be no
setpagedevice command whatsoever. Closing as UPSTREAM and waiting for the
upstream bug to be resolved and a patch coming to us.


Note You need to log in before you can comment on or make changes to this bug.